Last Comment Bug 756888 - Rollup of a bunch of small GCLI changes
: Rollup of a bunch of small GCLI changes
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: All All
: P2 normal (vote)
: Firefox 15
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
: Brian Grinstead [:bgrins]
Mentors:
Depends on:
Blocks: 745773 756890
  Show dependency treegraph
 
Reported: 2012-05-20 12:51 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-05-22 06:26 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Upload 1 (22.82 KB, patch)
2012-05-21 07:59 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
dcamp: review+
Details | Diff | Splinter Review
Upload 2 (22.98 KB, patch)
2012-05-21 11:06 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details | Diff | Splinter Review
Upload 3 (23.00 KB, patch)
2012-05-21 15:13 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details | Diff | Splinter Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-20 12:51:42 PDT
Includes:
- Split gcliblank out so we can have different markup for the output panel
  and tooltip panel
- Export the dimensions (start/end) of the current parameter to tooltip
- Set the default eagerness to SOMETIMES
- Fix the leftover issued from Bug 720641 comment 97
- Fix focus issues which caused the toolbar not to get focus properly when
  opened
- Use html:iframe not xul:iframe to workaround XUL issue
- Remove resize code which was a different attempt to workaround this issue
- Rename _anchor to _toolbar, since the use was confusing
- Change the anchor to be the input textbox
- Resize the width of the output panel as well as the height
- Don't use arrow panels
- Make the tooltip panel move horizontally with the current parameter
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-21 07:59:46 PDT
Created attachment 625649 [details] [diff] [review]
Upload 1
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-21 08:00:03 PDT
https://tbpl.mozilla.org/?tree=Try&rev=5b32c8cb3ad5
Comment 3 Dave Camp (:dcamp) 2012-05-21 09:38:23 PDT
Comment on attachment 625649 [details] [diff] [review]
Upload 1

Review of attachment 625649 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/shared/DeveloperToolbar.jsm
@@ +552,2 @@
>  
> +  this._panel.ownerDocument.defaultView.setTimeout(function() {

Can you include a comment explaining what you're working around with this setTimeout?
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-21 11:06:02 PDT
Created attachment 625695 [details] [diff] [review]
Upload 2

> "Can you include a comment explaining what you're working around with this setTimeout?"

Done.
Also this rebases for the MPL change.
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-21 11:06:22 PDT
https://tbpl.mozilla.org/?tree=Try&rev=b94c25fdbc97
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-21 15:13:07 PDT
Created attachment 625782 [details] [diff] [review]
Upload 3

Discovered an intermittent leak.
Fixed.
Comment 7 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-21 15:23:05 PDT
https://tbpl.mozilla.org/?tree=Try&rev=822d87d80351
Comment 8 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-22 00:53:46 PDT
https://tbpl.mozilla.org/?tree=Fx-Team&rev=a84e147b4d22
Comment 9 Tim Taubert [:ttaubert] 2012-05-22 06:26:00 PDT
https://hg.mozilla.org/mozilla-central/rev/a84e147b4d22

Note You need to log in before you can comment on or make changes to this bug.