Last Comment Bug 756972 - Support showing response bodies for "application/x-web-app-manifest+json" requests
: Support showing response bodies for "application/x-web-app-manifest+json" req...
Status: RESOLVED FIXED
[fixed by bug 673148]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Mihai Sucan [:msucan]
:
Mentors:
http://beatlab.com/mozilla/beatlab.we...
Depends on: async-webconsole
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 00:43 PDT by Matthew N. [:MattN] (PTO Jun. 29-30)
Modified: 2012-06-01 10:21 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Matthew N. [:MattN] (PTO Jun. 29-30) 2012-05-21 00:43:58 PDT
The "application/x-web-app-manifest+json" content-type is used for webapp manifests.

STR:
1) Open web console
2) Enable "Log Request and Response bodies"
3) Load load manifest URL (see URL field)
4) Click on HTTP request for .webapp

Actual result:
Unable to display responses of type ""

Expected result:
Show the response body like we do for JSON.
Comment 1 Mihai Sucan [:msucan] 2012-05-25 10:04:11 PDT
Thank you for the bug report!

I have added the MIME type you suggest to the list of known types for the Web Console, in patch "part 4" from bug 673148.
Comment 2 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-05-31 11:55:59 PDT
Marking this bug as fixed since the patch for bug 673148 included the fix for it.

Note You need to log in before you can comment on or make changes to this bug.