Last Comment Bug 756988 - Mark more SVG feature strings as supported
: Mark more SVG feature strings as supported
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Robert Longson
:
Mentors:
Depends on: 435513
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 02:22 PDT by Robert Longson
Modified: 2012-10-23 05:39 PDT (History)
4 users (show)
longsonr: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.55 KB, patch)
2012-05-21 02:22 PDT, Robert Longson
jwatt: review+
bbirtles: feedback+
Details | Diff | Review

Description Robert Longson 2012-05-21 02:22:47 PDT
Created attachment 625582 [details] [diff] [review]
patch

We do all the animation dom interfaces now (http://www.w3.org/TR/SVG/animate.html#DOMInterfaces) apart from animateColor which is deprecated.

I think it's time to mark animation as done too. The only other thing we don't do is wallclock timing I think which we're not planning to do (see http://brian.sol1.net/svg/2010/10/13/its-about-time/)
Comment 1 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2012-05-21 02:25:08 PDT
Comment on attachment 625582 [details] [diff] [review]
patch

Seems good to me, assuming Brian agrees.
Comment 2 Brian Birtles (:birtles) 2012-05-21 16:44:04 PDT
Comment on attachment 625582 [details] [diff] [review]
patch

I'm a little hesitant since we don't support wallclock timing, but I think it's ok since we've argued for it to be deprecated (and it probably will be in SVG 2).

The description for 'Animation' is that UA supports "the ‘animate’, ‘set’, ‘animateMotion’, ‘animateTransform’, ‘animateColor’ and ‘mpath’ elements" and I'm comfortable saying we do that given that animateColor has already been deprecated.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-05-26 05:12:15 PDT
https://hg.mozilla.org/mozilla-central/rev/61e64b3dba61

Note You need to log in before you can comment on or make changes to this bug.