Last Comment Bug 757177 - 4 unused variable warnings in new file SVGFragmentIdentifier.cpp
: 4 unused variable warnings in new file SVGFragmentIdentifier.cpp
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
: 759435 (view as bug list)
Depends on:
Blocks: buildwarning 512525
  Show dependency treegraph
 
Reported: 2012-05-21 13:11 PDT by Daniel Holbert [:dholbert]
Modified: 2012-05-29 12:53 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (2.35 KB, patch)
2012-05-21 13:24 PDT, Daniel Holbert [:dholbert]
longsonr: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2012-05-21 13:11:05 PDT
Bug 512525 added the new file SVGFragmentIdentifier.cpp with some unused variables in it:
{
../../../../../mozilla/content/svg/content/src/SVGFragmentIdentifier.cpp: In static member function 'static bool mozilla::SVGFragmentIdentifier::ProcessSVGViewSpec(const nsAString_internal&, nsSVGSVGElement*)':
../../../../../mozilla/content/svg/content/src/SVGFragmentIdentifier.cpp:151:27: warning: unused variable 'oldViewBoxPtr' [-Wunused-variable]
../../../../../mozilla/content/svg/content/src/SVGFragmentIdentifier.cpp:159:33: warning: unused variable 'oldPARPtr' [-Wunused-variable]
../../../../../mozilla/content/svg/content/src/SVGFragmentIdentifier.cpp:167:19: warning: unused variable 'oldZoomAndPanPtr' [-Wunused-variable]
../../../../../mozilla/content/svg/content/src/SVGFragmentIdentifier.cpp: At global scope:
../../../../../mozilla/content/svg/content/src/SVGFragmentIdentifier.cpp:14:25: warning: 'sZoomAndPanMap' defined but not used [-Wunused-variable]
}
Comment 1 Daniel Holbert [:dholbert] 2012-05-21 13:24:55 PDT
Created attachment 625737 [details] [diff] [review]
fix

Looks like all of these variables were just left over from an older patch-version, and they now have versions of themselves that live elsewhere (which are actually used).

The only "sZoomAndPanMap" that we use lives on nsSVGSVGElement (so the local one can go away), and the "oldXXX" variables now live in their various "SaveOldXXX" functions (so they can go away too).
Comment 2 Daniel Holbert [:dholbert] 2012-05-21 13:42:51 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/18f739e8ac9d
Comment 3 Ed Morley [:emorley] 2012-05-22 06:37:27 PDT
https://hg.mozilla.org/mozilla-central/rev/18f739e8ac9d
Comment 4 Robert Longson 2012-05-29 12:53:42 PDT
*** Bug 759435 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.