Header text doesn't resize properly after zooming out

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: williamr, Assigned: dbaron)

Tracking

({regression, testcase})

Trunk
Firefox 16
ARM
Android
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-fennec1.0 -, fennec+)

Details

(Whiteboard: [Engagement][User Engagement][readability], URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 625734 [details]
screenshot

Web page or screen you were on when you saw the issue: sfgate.com

Steps to reproduce:
1. Go to sfgate.com
2. Double tap an article to zoom in
3. Zoom out

What you expected: Link to mobile version in header is fully visible at the top of the page.

Actual: Full page is viewable (zoomed out) but the header text is cut off. Screenshot attached.
This seems to be font-inflation related. Loading the page initially inflates that header and makes it wider than the screen so it is cut off. Disabling font inflation prevents that from happening.

The behaviour I see on double-tap is different, though. If inflation is turned on, double-tapping in and back out seemed to reflow the page and wrap that header properly.

CCing dbaron as well.
blocking-fennec1.0: --- → ?
Whiteboard: [Engagement][User Engagement] → [Engagement][User Engagement][readability]
You don't need to zoom in. If you just let the page sit there, you'll see the font size change.

Turning off font-inflation makes this problem goes away.

Can we get a reduced testcase?
blocking-fennec1.0: ? → +
Keywords: testcase-wanted
Using today's nightly the header does not grow upon loading or on rotation. Would be good to find out what fixed this.
Keywords: testcase-wanted → regressionwindow-wanted
Good build: March 24th
Bad Build: March 25th

On March 24th the text was not inflated on March 25th the text is inflated on page first load. It seems that there are actually other patches that affected the behavior but this is when it was started.

Possible regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df1f94b2bdee&tochange=20a01901480f
Keywords: regressionwindow-wanted → regression
blocking-fennec1.0: + → .N+
This bug still occurs on the nightly (6/6/2012) on Samsung Galaxy S II.
Keywords: testcase-wanted
(In reply to adrian tamas from comment #4)
> Good build: March 24th
> Bad Build: March 25th
> 
> On March 24th the text was not inflated on March 25th the text is inflated
> on page first load. It seems that there are actually other patches that
> affected the behavior but this is when it was started.
> 
> Possible regression range:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=df1f94b2bdee&tochange=20a01901480f

That's probably not the actual regression range, but just something specific to this testcase, which was also affected by bug 711418, which was fixed in that range.
Created attachment 630718 [details]
smaller page

I broke down the page some, there is still a lot more that could potentially be removed.
1. Open the test page
2. Zoom in the test page
3. refresh the page.

You should see the bug.
Patch in bug 759755 makes the display consistent here, though consistent on the less preferred (larger) behavior.
(In reply to Naoki Hirata :nhirata from comment #8)
> Created attachment 630718 [details]
> smaller page
> 
> I broke down the page some, there is still a lot more that could potentially
> be removed.

should we leave the testcase-wanted whiteboard in here?   what else do we need to strip down more?
Fixed on m-c now that the first set of patches on bug 759755 landed.
Assignee: nobody → dbaron
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
(At least, the problem I cared about, which is that the size was inconsistent over time and/or certain user actions, is fixed.  But I guess the bug as originally described isn't.)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I believe this is the behavior we want, so possible a won't fix. In the very least it shouldn't be a .N+
blocking-fennec1.0: .N+ → ?
(In reply to David Baron [:dbaron] from comment #13)
> (At least, the problem I cared about, which is that the size was
> inconsistent over time and/or certain user actions, is fixed.  But I guess
> the bug as originally described isn't.)

I still see the text switch size between load and later.
blocking-fennec1.0: ? → .N+
I see it switch *during* load, when text at the bottom of the page finishes loading that's in a wider container than the text above it.  But I don't see it switch after load, I don't think.
Keywords: testcase-wanted → testcase
Blocks: 627842
tracking-fennec: --- → +
blocking-fennec1.0: .N+ → -
Looks like the stylesheets for attachment 630718 [details] are not longer available on sfgate.com :(. I can no longer reproduce this bug, so I'm going to close it as WFM. If this can be reproduced once again, please feel free to reopen.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.