background-color:transparent not supported for iframes

RESOLVED DUPLICATE of bug 50623

Status

RESOLVED DUPLICATE of bug 50623
18 years ago
10 years ago

People

(Reporter: dsuljoti, Assigned: kmcclusk)

Tracking

({css1, testcase})

Trunk
Future
x86
All
css1, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
This style property is not supported for iframes, and based on CSS2 specs all
elements should support it. Netscape 6 doesn't render the background of the
iframe transparent.

Ex.

iframe.html

<html>
<body bgcolor="black">
<iframe src="framesource.html" width="400" height="400" frameborder=0
allowtransparency="yes" style="background-color:transparent"></iframe>


framesource.html

<html>
<body>

<p>
this is a test
Please try a recent Mozilla build.  I believe that this has been fixed since NS6 
was released.
(Reporter)

Comment 2

18 years ago
I actually looked at it with the new build (2001032319) and I am still not 
seeing it behave correctly. Maybe I am using the tags wrong, is there another 
on/off switch for transparancy or just based on the style tag?
Hmm.  you're right.  This seems to not be working properly (tested with the
2001-04-11 Linux build).

Reassigning and status -> new.  Will attach a testcase.
Assignee: jst → kmcclusk
Status: UNCONFIRMED → NEW
Component: DOM Style → Compositor
Ever confirmed: true
Keywords: css1
OS: Windows NT → All
QA Contact: ian → petersen
Created attachment 30577 [details]
frame for the testcase
Keywords: testcase
The iframe should have a black background... it does not.  ccing hixie for
standards explications if any.
(Reporter)

Comment 7

18 years ago
the iframe should have black background, or if the parent window has an image 
as background, it should be see through...... transparent.

The IE implementation on IE 5.5 uses an extra tag, but is a good example of 
what is supposed to happen.
http://msdn.microsoft.com/workshop/author/dhtml/reference/properties/allowTransp
arency.asp

Comment 8

18 years ago
The iframe is painting with the correct (black) background color, but when the
document loads it flashes to white.  Something in the document load is causing
it to repaint to white.

If you use <iframe style="background-color:red !important"> it does the same
thing... it initially draws red but then flashes to white when the document loads.

Hard to tell, is this related to bug 49779? (referenced in html.css on frame and
iframe rules)
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 9

18 years ago
Looking at the testcase on win2k/2001020404 I see the flicker happening, but it
doesn't go to white, it goes to my default window color - a middle grey. Don't
know if this info helps, or of you cought it already.

Comment 10

18 years ago
*** Bug 85134 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
some status info.
a few days ago i bumped into this problem, too. (on 0.9.1)
just downloaded moz 0.9.2/win2k (Build ID : 2001062815) and verified that the
problem still exists. (displaying a white background)

Comment 12

18 years ago
Chnaging QA contact since it deals with iframe.
QA Contact: petersen → amar

Comment 13

18 years ago
Marking as a duplicate of bug 50263. It shouldn't even be necessary to specify a
transparent background, since the default value of background-color *is*
transparent.

*** This bug has been marked as a duplicate of 50623 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 14

18 years ago
It should be pointed out that "allowtransparency" is a Microsoft-proprietary
HTML element attribute, and as such its' use is deprecated in favor of CSS
"background-color: transparent". Implementing new proprietary extensions is
counterindicated when a standardized method is available.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.