duplicate data in stylesheets associated to XHTML documents !

RESOLVED FIXED in mozilla0.9

Status

()

Core
CSS Parsing and Computation
--
major
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: glazou, Assigned: Pierre Saslawsky)

Tracking

Trunk
mozilla0.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
I discovered this bug writing CSS tests for the W3C CSS WG.

If an XHTML document contains two <style> elements, the first one containing
two rules a and b, and the second one a rule c, Mozilla will in fact
internally keep a first stylesheet made of a and b, and a second one made
of a b and c !!!!!

Demo with the test case attached in the viewer, select Dump Stylesheet in
Debug menu. If you don't trust the viewer, switch to a windows box with Document
Inspector compiled (/mozilla/extensions/inspector) : same result.
(Reporter)

Comment 1

17 years ago
Created attachment 30573 [details]
test case showing bug
We're not resetting mStyleText in the nsXMLContentSink. Attaching a patch.
Created attachment 30588 [details] [diff] [review]
call Truncate on mStyleText
(Reporter)

Comment 4

17 years ago
r=glazman :-)  Tested on windows for the test case

Comment 5

17 years ago
sr=attinasi if you need it.
*** Bug 75234 has been marked as a duplicate of this bug. ***
Checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla0.9
You need to log in before you can comment on or make changes to this bug.