Closed Bug 757303 Opened 8 years ago Closed 8 years ago

crash on Galaxy Nexus with abort message: "Framebuffer not complete -- error 0x8cd6, mFBOTextureTarget 0xde1, aRect.width 1537, aRect.height 2305"

Categories

(Firefox for Android :: General, defect, critical)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 746730

People

(Reporter: nhirata, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-1fd57340-8013-4f60-a51e-b27332120520 .
============================================================= 
Frame 	Module 	Signature 	Source
0 	libmozalloc.so 	TouchBadMemory 	memory/mozalloc/mozalloc_abort.cpp:68
1 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:89
2 	dalvik-heap (deleted) 	dalvik-heap @0x7be11f 	
3 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x3127f40 	
4 	org.mozilla.fennec-1.apk 	org.mozilla.fennec-1.apk@0xe30d5f 	
5 	DroidSansFallback.ttf 	DroidSansFallback.ttf@0x3f8673 	
6 	DroidSansFallback.ttf 	DroidSansFallback.ttf@0x45906b 	
7 	dalvik-heap (deleted) 	dalvik-heap @0xe9e066b 	
8 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x325a273 	
9 	DroidSansFallback.ttf 	DroidSansFallback.ttf@0x40925f 	
10 	DroidSansFallback.ttf 	DroidSansFallback.ttf@0x2b811e 	
11 	DroidSansFallback.ttf 	DroidSansFallback.ttf@0x4f816a 	
12 	dalvik-heap (deleted) 	dalvik-heap @0xcce2577 	
13 	dalvik-heap (deleted) 	dalvik-heap @0x6ab3263 	
14 	libxul.so 	nsACString_internal::AppendFunc 	nsTSubstring.h:433
15 	libnspr4.so 	FuncStuff 	nsprpub/pr/src/io/prprf.c:1043
16 	libnspr4.so 	fill_n 	nsprpub/pr/src/io/prprf.c:205
17 		@0x64 	
18 	libxul.so 	nsACString_internal::ReplaceASCII 	xpcom/string/src/nsTSubstring.cpp:539
19 	libxul.so 	nsACString_internal::AppendFunc 	nsTSubstring.h:433
20 	libnspr4.so 	FuncStuff 	nsprpub/pr/src/io/prprf.c:1043
21 	libnspr4.so 	dosprintf 	nsprpub/pr/src/io/prprf.c:1028
22 	libnspr4.so 	PR_vsxprintf 	nsprpub/pr/src/io/prprf.c:1073
23 		@0x5f3aeb3e 	
24 	app_process 	app_process@0xcd4 	
25 	libxul.so 	mozilla::layers::LayerManagerOGL::CreateFBOWithTexture 	gfx/layers/opengl/LayerManagerOGL.cpp:1202
26 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:215
27 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
28 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
29 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
30 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	gfx/layers/opengl/LayerManagerOGL.cpp:809
31 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:443
32 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:416
33 	libxul.so 	mozilla::layers::CompositorParent::Composite 	gfx/layers/ipc/CompositorParent.cpp:285
34 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
35 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
36 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
37 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
38 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
39 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
40 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
41 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
42 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:27
43 	libc.so 	libc.so@0x12c4e 	
44 	libc.so 	libc.so@0x127a2 	
45 	libEGL.so 	libEGL.so@0x23e82

More crashes : 
https://crash-stats.mozilla.com/report/list?range_value=3&range_unit=days&date=2012-05-21&signature=TouchBadMemory%20|%20mozalloc_abort%20|%20dalvik-mark-stack%20%28deleted%29%400x3127f40&version=FennecAndroid%3A15.0a1

Last crash since build 20120519030527; 
Earliest crash on 15.0a1 : 20120518030516

Across all builds for the last 4 weeks : https://crash-stats.mozilla.com/query/query?product=FennecAndroid&version=ALL%3AALL&range_value=4&range_unit=weeks&date=05%2F22%2F2012+01%3A13%3A53&query_search=signature&query_type=contains&query=TouchBadMemory+|+mozalloc_abort+|+dalvik-mark-stack&reason=&build_id=&process_type=any&hang_type=any&do_query=1
Dupe of bug 705641 because of the same abort message?
Bug 741222 would help to aggregate same crashes.
Depends on: 741222
OS: All → Android
Hardware: All → ARM
Summary: crash in [@ TouchBadMemory | mozalloc_abort | dalvik-mark-stack (deleted)@0x3127f40 ] ; Possible font fallback issue? → crash in nsACString_internal::AppendFunc with abort message: "Framebuffer not complete -- error 0x8cd6, mFBOTextureTarget 0xde1, aRect.width 1537, aRect.height 2305" ; Possible font fallback issue?
bug 746730 has STR and a testcase.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Summary: crash in nsACString_internal::AppendFunc with abort message: "Framebuffer not complete -- error 0x8cd6, mFBOTextureTarget 0xde1, aRect.width 1537, aRect.height 2305" ; Possible font fallback issue? → crash on Galaxy Nexus with abort message: "Framebuffer not complete -- error 0x8cd6, mFBOTextureTarget 0xde1, aRect.width 1537, aRect.height 2305"
Duplicate of bug: 746730
You need to log in before you can comment on or make changes to this bug.