Last Comment Bug 757329 - [Azure] Deal with transform changing while a path is built
: [Azure] Deal with transform changing while a path is built
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Bas Schouten (:bas.schouten)
:
Mentors:
Depends on: 760863
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 22:09 PDT by Bas Schouten (:bas.schouten)
Modified: 2012-06-02 13:47 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Support changing transforms while emitting a path (6.20 KB, patch)
2012-05-21 22:09 PDT, Bas Schouten (:bas.schouten)
roc: review+
Details | Diff | Review

Description Bas Schouten (:bas.schouten) 2012-05-21 22:09:28 PDT
Created attachment 625895 [details] [diff] [review]
Support changing transforms while emitting a path

Since the new support for SVG stroke geometries we may apply a transform while a path is active and has not been drawn by a gfxContext. The Thebes-Azure wrapper does not support this behavior as it was not previously used. This patch adds (albeit slow), support for that behavior.
Comment 1 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-21 23:01:34 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8574f784774a
Attempted bustage fix:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bea719080c06

Note You need to log in before you can comment on or make changes to this bug.