Last Comment Bug 757442 - Native Fennec nightly always uses en-US for Java strings regardless of system language
: Native Fennec nightly always uses en-US for Java strings regardless of system...
Status: VERIFIED FIXED
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 15 Branch
: ARM Android
: -- major (vote)
: ---
Assigned To: Joey Armstrong [:joey]
:
Mentors:
Depends on:
Blocks: 713464 748470
  Show dependency treegraph
 
Reported: 2012-05-22 07:51 PDT by Adrian Tamas (:AdrianT)
Modified: 2016-07-29 14:25 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
+
verified
+
verified
-
15+


Attachments
logs (47.84 KB, text/plain)
2012-05-22 07:51 PDT, Adrian Tamas (:AdrianT)
no flags Details
menu screenshot (230.38 KB, image/png)
2012-05-22 07:51 PDT, Adrian Tamas (:AdrianT)
no flags Details
settings screenshot (221.13 KB, image/png)
2012-05-22 07:52 PDT, Adrian Tamas (:AdrianT)
no flags Details
Log Samsung Galaxy SII (75.45 KB, text/plain)
2012-05-31 04:06 PDT, Catalin Suciu [:csuciu]
no flags Details

Description Adrian Tamas (:AdrianT) 2012-05-22 07:51:26 PDT
Created attachment 626007 [details]
logs

Nightly 15.0a1 2012-05-22
Device: HTC Desire/HTC Desire Z/Samsung Galaxy Nexus
OS: Android 2.2.2/Android 2.3.3/Android 4.0.2

Steps to reproduce:
1. Install the latest Nightly multi-local build.
2. Use the app to navigate a few webpages.
3. Go to Settings and change the language( I tried Polish and Check on HTC Desire, French on HTC Desire Z and Samsung Galaxy Nexus).
4. Open Nightly and verify that the labels are changed.

Expected results:
All the labels are changed to the correct language.

Actual results:
Only the more button on the non ICS phone is changed the rest remain in English.

Note:
The issue is not reproducible on Aurora 14.0a2 2012-05-21.
Comment 1 Adrian Tamas (:AdrianT) 2012-05-22 07:51:57 PDT
Created attachment 626008 [details]
menu screenshot
Comment 2 Adrian Tamas (:AdrianT) 2012-05-22 07:52:26 PDT
Created attachment 626009 [details]
settings screenshot
Comment 3 Aaron Train [:aaronmt] 2012-05-22 07:57:51 PDT
Is this a regression, or is this something expected on Nightly builds? I do see the size difference on Nightly (~17MB), vs en-US (~15MB).
Comment 4 Axel Hecht [pto-Aug-30][:Pike] 2012-05-22 08:05:05 PDT
I can reproduce this, but it seems to only affect the native UI bits.

The neterror pages show up in German for me, for example.

More buildlogic regressions?
Comment 5 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2012-05-22 20:41:55 PDT
(In reply to Axel Hecht [:Pike] from comment #4)
> I can reproduce this, but it seems to only affect the native UI bits.
> 
> The neterror pages show up in German for me, for example.
> 
> More buildlogic regressions?

from irc w/khuey, ted:

1) there were some makefile changes 16may, but none that we can recall in this area since then.

2) Is it possible this has been broken since 16may? Can you clarify when this started to happen?
Comment 6 Adrian Tamas (:AdrianT) 2012-05-23 00:59:35 PDT
Good build: May 12th

Bad build: May 13th

Possible regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=22a58090fa70&tochange=c758cc9b60e5

On these builds I am seeing issues with loading about:home after a language change, however these issues are not reproducible on the latest Nightly.
Comment 7 Axel Hecht [pto-Aug-30][:Pike] 2012-05-23 02:04:44 PDT
Adrian, thanks for the regression range.

http://hg.mozilla.org/mozilla-central/rev/c115c58ef2b1 is in there, aka bug 748470
Comment 8 Aaron Train [:aaronmt] 2012-05-25 10:42:28 PDT
Rel-eng issue?
Comment 9 Axel Hecht [pto-Aug-30][:Pike] 2012-05-25 10:44:05 PDT
nope, build magic more likely. Joey was the author of the build magic patch within the regression range.
Comment 10 Catalin Suciu [:csuciu] 2012-05-30 07:28:08 PDT
Reproducible also on:
Aurora 14.0a2 (2012-05-30)

Device: Samsung Galaxy SII (2.3.4)(Espanol)
Comment 11 Brad Lassey [:blassey] (use needinfo?) 2012-05-30 11:55:46 PDT
Matt, can you please investigate this. We'd like to know if this is a channel specific issue (i.e. due to locales not being complete in aurora and nightly) and if we can nail down what's causing this.

Please renom if it is not severe enough to warrent blocking after your investigation.
Comment 12 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-05-30 12:04:13 PDT
Was fennec quit out of before the switch of the language?  I don't see this issue if I quit out of fennec first on Aurora 14.0a2 2012/5/30.  This is on Samsung Galaxy S II.

Also to note, I can see French and Italian just fine.
Comment 13 Axel Hecht [pto-Aug-30][:Pike] 2012-05-30 12:18:37 PDT
This is central/nightly only, AFAIK. If it's the build logic that I suspect, it wouldn't affect aurora.
Comment 14 Catalin Suciu [:csuciu] 2012-05-31 04:03:07 PDT
I'm still able to reproduce the bug on my device (Samsung Galaxy SII - Android 2.3.4):

Steps:
1. Install Aurora multi-local 14.0a2 (2012-05-30).
2. Start Aurora with the device OS set to English
3. Go to Menu -> More and Quit Aurora 
4. Go to Settings and change the language( I tried Español and Português)
5. Open Nightly and verify that the labels are changed.

Expected results:
All the labels are changed to the correct language.

Actual results:
Only the More button is localized, the rest remain in English.

Unable to reproduce on LG Optimus 2x (Android 2.2)and HTC Desire (Android 2.2)

See the attached log.
Comment 15 Catalin Suciu [:csuciu] 2012-05-31 04:06:43 PDT
Created attachment 628673 [details]
Log Samsung Galaxy SII
Comment 16 Aaron Train [:aaronmt] 2012-05-31 10:37:44 PDT
re: Johnath yesterday, restarting phone does not correct the behaviour. 

Tested:

System device language; from: English (United States), to: Français - while Nightly/Aurora are running yields: en-US
System device language; from: English (United States), to: Français - while Nightly/Aurora are not running yields: en-US
Comment 17 Matt Brubeck (:mbrubeck) 2012-05-31 10:50:31 PDT
So, is there any situation where en-US strings are *not* used for Java UI elements (like the options menu)?  In my testing, en-US is *always* used, even if the system is set to a different locale from the start.
Comment 18 Matt Brubeck (:mbrubeck) 2012-05-31 12:12:39 PDT
(In reply to adrian tamas from comment #6)
> Good build: May 12th
> Bad build: May 13th

Comparing these builds, I see that resources.arsc is about 60% smaller in the May 13th build:

May 12: 147440  resources.arsc
May 13:  57592  resources.arsc

So it appears likely that all the Java strings are not being packed correctly in multi-locale nightlies.  I agree this is likely a regression from bug 748470.  Joey, do you know what might cause this?  If not, can back out bug 748470 to see if it fixes this?
Comment 19 Matt Brubeck (:mbrubeck) 2012-05-31 12:14:13 PDT
> If not, can back out bug 748470 to see if it fixes this?

I meant "can *we* back out..."

Un-setting blocking-fennec1.0 and tracking-fennec:14+ because this appears to be a regression from a Firefox 15-only patch, so it will not affect the 14.0 release.
Comment 20 Joey Armstrong [:joey] 2012-06-07 09:05:16 PDT
makefile edits from 748470 allow make to behave properly wrt dependencies, only regenerating files when content changes are made instead of regenerating on every call.

What may be missing/still needed are locale specific deps for handling multi-locale generation in parallel.  Working on a multi-locale build now to try and track this down.

[ps] unit tests will also need to be written to detect problems like these automatically.
Comment 21 Aaron Train [:aaronmt] 2012-06-11 07:15:50 PDT
Any update?
Comment 22 Joey Armstrong [:joey] 2012-06-11 08:18:44 PDT
Revert the patch if needed, locale deps may take a little while to track down.
Comment 23 Alex Keybl [:akeybl] 2012-06-11 09:09:18 PDT
(In reply to Joey Armstrong [:joey] from comment #22)
> Revert the patch if needed, locale deps may take a little while to track
> down.

Joey - can you prepare the backout patches for bug 748470 and nominated for mozilla-aurora approval?
Comment 24 Aki Sasaki [:aki] 2012-06-13 09:33:32 PDT
Bug 748470 was backed out.
Aurora's nightly should have the fix as of Tuesday night.
Mozilla-central's nightly should have the fix as of last night.
Comment 25 Alex Keybl [:akeybl] 2012-07-16 08:05:58 PDT
(In reply to Aki Sasaki [:aki] from comment #24)
> Bug 748470 was backed out.
> Aurora's nightly should have the fix as of Tuesday night.
> Mozilla-central's nightly should have the fix as of last night.

I've marked the status to reflect my understanding (please correct me if wrong). Can this be closed out now?
Comment 26 Aki Sasaki [:aki] 2012-07-16 09:52:31 PDT
Aiui, this should be fixed, and resolving will put this in QA's list for verification.
Comment 27 Adrian Tamas (:AdrianT) 2012-09-27 06:42:06 PDT
Unable to reproduce the issue on:

Firefox Mobile 16.0b5 / Firefox Mobile 15
Samsung Galaxy R (Android 2.3.4)

Marking as verified on Firefox Mobile 16

Note You need to log in before you can comment on or make changes to this bug.