Closed Bug 75748 Opened 19 years ago Closed 19 years ago

nested table is inheritting the wrong bgcolor

Categories

(Core :: Layout: Tables, defect)

x86
Windows NT
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 70831

People

(Reporter: cam_hart, Assigned: karnaze)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1) Gecko/20010323
BuildID:    2001032319

If you have on table with a background colour set to white, and the td
background colour set to red, and nest a table in the td, the new table gets the
background colour of the parent table, not the td.

Reproducible: Always
Steps to Reproduce:
1.go to the url

or try the following html out:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">
<html>
<head>
</head>
<body>
<!--outer table for white border-->
<table cellspacing="10" border="0" bgcolor="#ffffff" width="100%">
	<tr>
		<td bgcolor="#751569">
			test0
			<!-- table definition here -->
			<table width="100%">
				<tr>
					<td>this bg</td>
					<td>should</td>
				</tr>
				<tr>
					<td>be</td>
					<td>purple</td>
				</tr>
			</table>
		</td>
	</tr>
</table>
</body>
</html>


Actual Results:  background colour in nested table is white

Expected Results:  background colour in nested tables should be purple

I've seen similar looking bugs listed, 70831 and 46480 for example.
This is actually just bug 70831....  On my computer, the inner table gets a gray
background (default background), not white.

*** This bug has been marked as a duplicate of 70831 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
 This bug was fixed somewhere and the bg color for the innertable is purple from
the testcase
fixed
You need to log in before you can comment on or make changes to this bug.