Last Comment Bug 757594 - Implicit Makefile rule changes in bug 748001 broke libvpx's obj_int_extract
: Implicit Makefile rule changes in bug 748001 broke libvpx's obj_int_extract
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla15
Assigned To: Timothy B. Terriberry (:derf)
:
Mentors:
Depends on:
Blocks: 748001
  Show dependency treegraph
 
Reported: 2012-05-22 13:23 PDT by Timothy B. Terriberry (:derf)
Modified: 2012-05-23 04:50 PDT (History)
2 users (show)
tterribe: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add explicit rules for obj_int_extract sources to libvpx (2.14 KB, patch)
2012-05-22 14:52 PDT, Timothy B. Terriberry (:derf)
khuey: review+
Details | Diff | Splinter Review

Description Timothy B. Terriberry (:derf) 2012-05-22 13:23:26 PDT
Bug 748001 got rid of some implicit rules that media/libvpx/Makefile.in was relying on to make the obj_int_extract approach to extracting C struct offsets for the libvpx asm work. We didn't notice because
a) the decoder only needs these offsets on ARM, and ARM always uses gcc, which does this a much better way (without obj_int_extract), and
b) the encoder is not built by default.
Comment 1 Timothy B. Terriberry (:derf) 2012-05-22 14:52:17 PDT
Created attachment 626197 [details] [diff] [review]
Add explicit rules for obj_int_extract sources to libvpx

Try results with encoder (and error concealment) enabled incoming: https://tbpl.mozilla.org/?tree=Try&rev=e2864eec0017
Comment 2 Timothy B. Terriberry (:derf) 2012-05-22 19:57:41 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/384f2d1f7b49
Comment 3 Ed Morley [:emorley] 2012-05-23 04:50:25 PDT
https://hg.mozilla.org/mozilla-central/rev/384f2d1f7b49

Note You need to log in before you can comment on or make changes to this bug.