Last Comment Bug 757600 - Ogg Opus header version bump
: Ogg Opus header version bump
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Ralph Giles (:rillian) needinfo me
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 13:47 PDT by Ralph Giles (:rillian) needinfo me
Modified: 2012-05-23 04:51 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Update the Opus version field parser (3.62 KB, patch)
2012-05-22 13:57 PDT, Ralph Giles (:rillian) needinfo me
cpearce: review+
Details | Diff | Review
Update the Opus version field parser (2.64 KB, patch)
2012-05-22 16:43 PDT, Ralph Giles (:rillian) needinfo me
giles: review+
Details | Diff | Review

Description Ralph Giles (:rillian) needinfo me 2012-05-22 13:47:59 PDT
The Ogg Opus header had a version bump recently, with no other changes. We're now supposed to accept any stream with version > 16, i.e. when the high four bits are zero.
Comment 1 Timothy B. Terriberry (:derf) 2012-05-22 13:54:36 PDT
(In reply to Ralph Giles (:rillian) from comment #0)
> We're now supposed to accept any stream with version > 16, i.e. when the

< 16, to be clear.
Comment 2 Ralph Giles (:rillian) needinfo me 2012-05-22 13:57:45 PDT
Created attachment 626170 [details] [diff] [review]
Update the Opus version field parser

Proposed fix.
Comment 3 Chris Pearce (:cpearce) 2012-05-22 16:34:54 PDT
Comment on attachment 626170 [details] [diff] [review]
Update the Opus version field parser

Review of attachment 626170 [details] [diff] [review]:
-----------------------------------------------------------------

Since mVersion is only used once, just store it in a local variable rather than adding a datafield to nsOpusState.

r+ with that change.
Comment 4 Ralph Giles (:rillian) needinfo me 2012-05-22 16:43:05 PDT
Created attachment 626247 [details] [diff] [review]
Update the Opus version field parser

Updated patch addressing review comments.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-05-22 17:41:35 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f93a650e8a8c
Comment 6 Ed Morley [:emorley] 2012-05-23 04:51:42 PDT
https://hg.mozilla.org/mozilla-central/rev/f93a650e8a8c

Note You need to log in before you can comment on or make changes to this bug.