Last Comment Bug 757671 - IonMonkey: Values should be at least word aligned on ARM
: IonMonkey: Values should be at least word aligned on ARM
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: ARM Linux
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 17:15 PDT by Marty Rosenberg [:mjrosenb]
Modified: 2012-08-02 13:44 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
/home/mrosenberg/patches/fixAlignment-r0.patch (2.24 KB, patch)
2012-05-22 17:15 PDT, Marty Rosenberg [:mjrosenb]
sstangl: review+
Details | Diff | Splinter Review

Description Marty Rosenberg [:mjrosenb] 2012-05-22 17:15:49 PDT
Created attachment 626260 [details] [diff] [review]
/home/mrosenberg/patches/fixAlignment-r0.patch

I noticed this while running on my Nexus-S a few weeks ago, then got derailed when my desktop bit the dust.
(gdb) x/i $pc
=> 0x5b00ba8c:	strd	r2, r3, [r1]
(gdb) p/x $r1
$1 = 0x5e487fd1

I am not sure why there aren't any debug symbols, but this is in the process of copying data into the constant table attached to every script, and this data is misaligned, so it crashes.
Comment 1 Sean Stangl [:sstangl] 2012-05-29 17:30:42 PDT
Comment on attachment 626260 [details] [diff] [review]
/home/mrosenberg/patches/fixAlignment-r0.patch

Review of attachment 626260 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/ion/Ion.cpp
@@ +398,5 @@
>      cacheEntries_(0),
>      refcount_(0)
>  {
>  }
> +static const int DataAlignment = 4;

nit: needs newlines around this line.
Comment 2 Marty Rosenberg [:mjrosenb] 2012-08-01 13:36:15 PDT
landed: http://hg.mozilla.org/projects/ionmonkey/rev/aff52d7f5924
looks like this short patch got lost amongst a large number that I committed that day.
Comment 3 Marty Rosenberg [:mjrosenb] 2012-08-02 13:44:14 PDT
And actually closing the issue.

Note You need to log in before you can comment on or make changes to this bug.