Last Comment Bug 757703 - support unitless values for mpadded attributes
: support unitless values for mpadded attributes
Status: RESOLVED FIXED
: dev-doc-complete, regression
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Other Branch
: x86_64 All
: -- normal (vote)
: mozilla15
Assigned To: Frédéric Wang (:fredw)
:
: Anthony Jones (:kentuckyfriedtakahe, :k17e)
Mentors:
http://www.w3.org/Math/draft-spec/cha...
Depends on:
Blocks: 677036
  Show dependency treegraph
 
Reported: 2012-05-22 19:55 PDT by Karl Tomlinson (:karlt)
Modified: 2012-11-29 10:51 PST (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch V1 (2.03 KB, patch)
2012-05-24 13:30 PDT, Frédéric Wang (:fredw)
karlt: review+
Details | Diff | Splinter Review
Patch V2 (2.17 KB, patch)
2012-05-25 04:53 PDT, Frédéric Wang (:fredw)
karlt: review+
Details | Diff | Splinter Review

Description Karl Tomlinson (:karlt) 2012-05-22 19:55:13 PDT
The regular expression for mpadded attributes in MathML 3.0 First Edition required units, but this was inconsistent with what was implied in the text.

The editor's draft for the Second Edition has now updated the regular expression to allow unitless values, which is what was intended and is consistent with the text.

http://lists.w3.org/Archives/Public/www-math/2012May/0027.html

Bug 677036 removed the special case for "0" in mpadded attributes, so that part of this bug is a regression.  Other unitless values have not been previously supported in Gecko.
Comment 1 Frédéric Wang (:fredw) 2012-05-22 23:38:38 PDT
I think we should really only support unitless "0" as in CSS:

http://www.w3.org/TR/css3-values/#lengths

See my comment here:
http://lists.w3.org/Archives/Public/www-math/2012May/0028.html
Comment 2 Frédéric Wang (:fredw) 2012-05-24 13:30:06 PDT
Created attachment 626941 [details] [diff] [review]
Patch V1

This patch should restore support for the "0" case and treats other unitless values as a multiple of the base size.
Comment 3 Karl Tomlinson (:karlt) 2012-05-24 19:38:27 PDT
Comment on attachment 626941 [details] [diff] [review]
Patch V1

>+      aCSSValue.SetPercentValue(floatValue);

It probably doesn't make any difference in practice, but it would be more consistent to use SetFloatValue(floatValue, eCSSUnit_Number).

I'm also happy if you only restore the "0" until the MathML WG makes a decision.
You made some good points against unitless values, but my guess is that they are unlikely to make a change if the intention was to allow unitless values.
Comment 4 Frédéric Wang (:fredw) 2012-05-25 04:53:52 PDT
Created attachment 627186 [details] [diff] [review]
Patch V2
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-05-27 20:33:28 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/34af06cc57f6
Comment 6 Ed Morley [:emorley] 2012-05-28 09:42:21 PDT
https://hg.mozilla.org/mozilla-central/rev/34af06cc57f6
Comment 7 Florian Scholz [:fscholz] (MDN) 2012-11-29 10:51:03 PST
A note on this topic has been added to
https://developer.mozilla.org/en-US/docs/Firefox_15_for_developers#MathML

We probably don't need more docs here (see bug 677036#c30 ff).

Note You need to log in before you can comment on or make changes to this bug.