buggy select list for a SELECT form widget with font specified

VERIFIED DUPLICATE of bug 69785

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 69785
17 years ago
17 years ago

People

(Reporter: thomas.morin, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: 20010401208
running under Debian GNU/Linux 2.3 with gtk 1.2.10

The scroll bar of a select form widget with the SIZE attribute specified is not
displayed.

The following code produce a nice selection list with a scrollbar :

<SELECT SIZE="3" NAME="list">
           <OPTION VALUE=123 SELECTED>1
           <OPTION VALUE=134> 2
           <OPTION VALUE=232> 3
           <OPTION VALUE=232> 4
           <OPTION VALUE=232> 5
</SELECT>


If it is between a <FONT FACE="Helvetica"> and a </FONT> this piece of code
produces a buggy widget : no scrollbar is dispayed and the update of the content
of the list is not updated correctly when you try to browse the list with the up
and down keyboard keys.

Note that the SIZE atribute is crucial here : it is supposed to have the list
displayed in an already expanded list (as opposed to a drop down list).
(Reporter)

Comment 1

17 years ago
Demo HTML code available at :

http://horus.webmotion.com/~thomas/mozilla/
known problem. :(

*** This bug has been marked as a duplicate of 69785 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Yep.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.