unable to pinch zoom out after switching tabs and back

VERIFIED FIXED in Firefox 14

Status

()

defect
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: tchung, Assigned: wesj)

Tracking

({regression})

Trunk
Firefox 15
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, blocking-fennec1.0 betaN+)

Details

()

Attachments

(2 attachments)

Posted file logcat
I am unable to pinch zoom back out when first zooming into a page, switching a tab, and then switching back to the previous tab state.   Trying to pinch zoom out is stuck.

See screencast: http://youtu.be/7ARd9J1f6XY.   Skip to the end to see what i'm talking about.

Also attaching logcat, although i didnt see any errors thrown.

REpro:
1) install 5-23-2012 nightly, HTC Sensation, Android 2.3.4
2) visit site and pinch zoom into text area:  http://www.cnn.com/2012/05/23/opinion/blank-facebook-ipo/index.html?hpt=hp_t1
3) switch tabs to something else (eg. huffingtonpost.com)
4) switch back to the previous tab, and notice site should still be zoomed in from last state
5) try pinch zooming back out.   Verify its not doing it

Expected:
- switch tabs and able to zoom back out

Actual:
- switching tabs and back, zooming back out is broken
Hmm, I couldn't reproduce this, but after switching back to the tab I noticed that pinch zooming out was slower (it was zooming out less for the same finger movement than right after I zoomed in).

And then I accidentally tapped on a few links and clicked back, and ended up reproducing something that looks a lot like bug 748509 :(
I'm guessing this is related to page with user-scalable=false set. Digging a bit more....
Here's some more detailed STR for the first part (slow zooming):

1. Open up the CNN page in a new tab
2. double-tap the search text field in the upper right
3. switch to a different tab
4. switch back to CNN
5. notice that if you pinch from the corners of the screen all the way in, it looks like nothing is happening -- we're zooming a very small amount.  if you keep doing it, eventually you'll zoom all the way back out.

If, once the page is fully zoomed out, you zoom in and then zoom out, zooming out shuold be fast (pinch from middle to edges gets you very close, and the opposite will get you back to the original zoom).
We're not reseting minZoom and maxZoom when you switch tabs. Testing a patch....
Posted patch PatchSplinter Review
Fixes this for me. Maybe we want to just use the tab as the sole source of truth though....
Assignee: nobody → wjohnston
Attachment #626574 - Flags: review?(bugmail.mozilla)
Comment on attachment 626574 [details] [diff] [review]
Patch

Review of attachment 626574 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch, thanks.
Attachment #626574 - Flags: review?(bugmail.mozilla) → review+
Comment on attachment 626574 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 707571
User impact if declined: Switching between tabs can result in pages that are at the wrong scale and that can't be scaled (or the opposite, pages that should be unscalable would end up at the wrong scale and allow pinch zoom). I believe loading a new page resets min and max zoom so they should work again.
Testing completed (on m-c, etc.): Landed on MC May 24.
Risk to taking this patch (and alternatives if risky): Low risk. At worst, we're doing redundant work setting the zoom to what it should be.
String or UUID changes made by this patch: None.
Attachment #626574 - Flags: approval-mozilla-aurora?
blocking-fennec1.0: ? → betaN+
Attachment #626574 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This needs to land asap on MOBILE140_2012052310_RELBRANCH as well as tip of mozilla-aurora to minimize the code change between what QA has already been testing and what we'll actually release this week.
qa wanted : verification needed.
I am unable to reproduce the issue on Firefox 14.0b3 build 2 but I am able to reproduce the issue on Aurora 14.0a2 2012-05-24 on HTC Desire Z running Android 2.3.3.
(In reply to adrian tamas from comment #14)
> I am able
> to reproduce the issue on Aurora 14.0a2 2012-05-24 on HTC Desire Z running
> Android 2.3.3.

That build doesn't have the fix.
https://hg.mozilla.org/mozilla-central/rev/01c405adc966
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Verified fix on fx14 beta 3
Keywords: qawanted
Verified fixed on 5-30-2012 nightly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.