Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Bugs with resolution MOVED cannot be edited

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ken Brown, Assigned: Frédéric Buclin)

Tracking

({regression})

4.0.2
Bugzilla 4.0
regression
Bug Flags:
approval +
approval4.4 +
blocking4.4 +
approval4.2 +
blocking4.2.4 +
approval4.0 +
blocking4.0.9 +

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_7_4; en-US) AppleWebKit/533.21.1+(KHTML, like Gecko, Safari/533.19.4) Version/5.11.1 OmniWeb/622.18.0

Steps to reproduce:

Try to add a comment or a "See Also" URL to a bug with resolution "MOVED".


Actual results:

An error page appears with "You cannot set the resolution of a bug to MOVED without moving the bug."


Expected results:

The resolution was not changing.  It was _already_ MOVED so it should not have triggered this error.

Note that if I change the value "MOVED" to check "Enabled for bugs" I can then add comments and URLs, etc.  But this leaves that resolution open to anyone to use for any bug even if it's not moved.

See also Bug 431730 - "Bugs with resolution MOVED cannot be edited anymore".  This is evidently another regression of the same symptom.
This is a duplicate of Bug 431730. Please mark it accordingly.
(Assignee)

Comment 2

5 years ago
I can reproduce the issue with 4.5. This means the extension is really broken and unusable.
Status: UNCONFIRMED → NEW
Depends on: 556422
Ever confirmed: true
Flags: blocking4.4+
Flags: blocking4.2.4+
Target Milestone: --- → Bugzilla 4.2
(Assignee)

Comment 3

5 years ago
Created attachment 666195 [details] [diff] [review]
patch, v1

We must not throw an error if the resolution was already set to MOVED.
Assignee: create-and-change → LpSolit
Status: NEW → ASSIGNED
Attachment #666195 - Flags: review?(glob)
(Assignee)

Comment 4

5 years ago
Let's take it for 4.0 too, which is where this extension has been implemented. In fact, the extension never worked correctly once a bug was marked as MOVED. This patch applies cleanly to all branches and works as expected.
Flags: blocking4.0.9+
Target Milestone: Bugzilla 4.2 → Bugzilla 4.0
(Assignee)

Updated

5 years ago
Keywords: regression
Comment on attachment 666195 [details] [diff] [review]
patch, v1

r=glob
Attachment #666195 - Flags: review?(glob) → review+
(Assignee)

Updated

5 years ago
Flags: approval4.4+
Flags: approval4.2+
Flags: approval4.0+
Flags: approval+
(Assignee)

Comment 6

5 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified extensions/OldBugMove/Extension.pm
Committed revision 8405.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.4/
modified extensions/OldBugMove/Extension.pm
Committed revision 8401.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified extensions/OldBugMove/Extension.pm
Committed revision 8142.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified extensions/OldBugMove/Extension.pm
Committed revision 7725.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.