Last Comment Bug 758120 - Symantec Japan site is broken with gfx.content.azure.enabled:true
: Symantec Japan site is broken with gfx.content.azure.enabled:true
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: Bas Schouten (:bas.schouten)
:
: Milan Sreckovic [:milan]
Mentors:
http://www.symantec.com/ja/jp/
: 758137 (view as bug list)
Depends on:
Blocks: 715768
  Show dependency treegraph
 
Reported: 2012-05-23 23:23 PDT by pal-moz
Modified: 2012-05-25 15:44 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot (512.64 KB, image/jpeg)
2012-05-23 23:23 PDT, pal-moz
no flags Details
Block attempts to do manual subpixel AA on bitmap fonts. (2.84 KB, patch)
2012-05-24 08:19 PDT, Bas Schouten (:bas.schouten)
jfkthame: review+
Details | Diff | Splinter Review

Description pal-moz 2012-05-23 23:23:04 PDT
Created attachment 626704 [details]
Screenshot

Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120523164348

text disappears.
Comment 1 Bas Schouten (:bas.schouten) 2012-05-24 08:19:49 PDT
Created attachment 626818 [details] [diff] [review]
Block attempts to do manual subpixel AA on bitmap fonts.

This is a little hacky as the code to do detect this should really be inside Azure. However there's a lot of font logic which needs to move, and right now it doesn't seem very useful to duplicate a bunch of font table stuff into Azure. So I think this is the best way to go for now.
Comment 2 Bas Schouten (:bas.schouten) 2012-05-24 08:20:32 PDT
*** Bug 758137 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan Kew (:jfkthame) 2012-05-24 08:39:21 PDT
Comment on attachment 626818 [details] [diff] [review]
Block attempts to do manual subpixel AA on bitmap fonts.

Review of attachment 626818 [details] [diff] [review]:
-----------------------------------------------------------------

I'd usually prefer using a stack-based helper to set/restore state like this, so that there's no risk of accidentally leaving the changed state if someone adds an early return in the future. But I see the same code pattern is already present for setting/restoring the transform, so I suppose it's fine to do this for now, assuming it resolves the problem.
Comment 4 Bas Schouten (:bas.schouten) 2012-05-24 08:44:49 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c4d9d027f2b
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-05-25 08:31:14 PDT
https://hg.mozilla.org/mozilla-central/rev/0c4d9d027f2b
Comment 6 pal-moz 2012-05-25 15:44:17 PDT
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120525113255

All fine.
thank you.

Note You need to log in before you can comment on or make changes to this bug.