Sometimes content only renders in the bottom half of the screen

VERIFIED FIXED

Status

()

Firefox for Android
Toolbar
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Ehsan, Assigned: kats)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-fennec1.0 -, fennec+)

Details

(Whiteboard: [viewport])

Attachments

(1 attachment)

I've seen this a few times on Aurora, and I finally think I can roughly say what I did to cause it.  I copied a URL from the stock browser, started Aurora, and as it was loading Gecko showing the title of a tab that was about to be restored, I tapped the URL bar to bring up the keyboard, and pasted the URL and hit Go.

Then the keyboard was dismissed, but the content area's height was not increased, and was shifted down, so effectively content was only being rendered in the bottom half of the browser, and the top half was empty (white).
blocking-fennec1.0: ? → +
Keywords: qawanted
Assignee: nobody → bugmail.mozilla
Ehsan, can you take your device over to Kats to show him what's going on?
(Reporter)

Comment 2

6 years ago
(In reply to Brad Lassey [:blassey] from comment #1)
> Ehsan, can you take your device over to Kats to show him what's going on?

I would be happy to, but he's not at the office today, and this bug doesn't happen every time unfortunately...  I'll take some screenshots the next time it happens.
I've seen this happen occasionally as well but it's very hard to pin down. I think I need to audit our behaviour on keyboard showing/hiding and make sure it's sane.

I'll be in the office tomorrow so if you have reliable STR you can show me then.
layout for now.
Whiteboard: [layout]
(Reporter)

Comment 5

6 years ago
FWIW, I would be very surprised if this is related to layout.  The page is laid out correctly, only in a smaller viewport.
Yeah, it should be tagged as viewport (that's what elancaster and I discussed on IRC, probably just a mistake)
Whiteboard: [layout] → [viewport]
Depends on: 758633
I've seen this before and it's hard to reproduce on Droid Pro.

It only occurs when you have the VKB up during the time fennec is busy in the background and dismiss the keyboard when it's not expecting it.

It's some sort of race condition, I believe?
blocking-1.0 bug update: Until I have reliable STR for this I'm going to continue to focus on bug 757362 instead since I feel it will be a better use of time. Note also that the severity of this bug may be reduced with the landing of bug 758635 but without STR there's no way to tell (and I don't want to request uplift for bug 758635 without being sure).
tracking-fennec: --- → 15+
blocking-fennec1.0: + → -
Can't seem to repro currently.
I am only able to reproduce the issue for a few seconds if I go to a page with a search field (msnbc.com, cnn.com), tap on the field to open the keyboard and then minimize and maximize Firefox. This would cause the keyboard to be dismissed with the app in the background and repaint a few seconds late the area when focusing Firefox. I will continue to try and get some STR.

Tested on:
HTC Desire
Android 2.2

Comment 11

6 years ago
When this bug occurs, I've been able to fix things by creating a new tab.
I got it occuring once when doing these steps:

STR:
1. open page to http://people.mozilla.com/~nhirata/html_tp/formsninput.html
2. click in a text field to bring up VKB
3. select the menu button on the android device
4. select more -> downloads
5. hit the back button to dismiss the keyboard

I can't seem to reproduce, I believe because the about:downloads is cached.  Does removing all data from fennec remove the cache as well?  or would I have to do that manually?

In either cases, I don't think that the VKB should be up when the menu is invoked...

Updated

6 years ago
Keywords: qawanted
Component: General → Graphics, Panning and Zooming
Taking this off my list since there's nothing I can do without STR right now.
Assignee: bugmail.mozilla → nobody
qawanted to retest
tracking-fennec: 15+ → ?
Keywords: qawanted

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Created attachment 713761 [details]
screenshot

I can consistently reproduce this on Nightly using a Droid RAZR with these STR:
1) Add a shortcut to your home screen for some page such as google.com
2) Close Fennec
3) Tap the shortcut to open Fennec
4) Immediately when the URL bar is visible, tap it to go to the AwesomeScreen
5) Type anything in the AwesomeScreen (at least one letter)
6) Hit back

This works about 75% of the time for me. It only happens when using the Swype keyboard (setting the stock keyboard doesn't show this bug). Screenshot attached.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Kats, can you reproduce with swype? If not, please talk to brian.
Assignee: nobody → bugmail.mozilla
tracking-fennec: ? → +
Depends on: 844275
This should be fixed in the March 1 nightly with the landing of bug 844275. Please reopen if this still happens. (Brian, since you were the most recent person to be able to reproduce it consistently, can you verify it is fixed now?)
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 845360
Nice, looks like this fixed it.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.