Last Comment Bug 758248 - fuelApplication.js Window._shutdown() removeEventListener() call is wrong
: fuelApplication.js Window._shutdown() removeEventListener() call is wrong
Status: VERIFIED FIXED
[fixed by bug 750454]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Justin Lebar (not reading bugmail)
:
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on: 347930 750454
Blocks: 758102
  Show dependency treegraph
 
Reported: 2012-05-24 09:21 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-06-24 04:41 PDT (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
wontfix
wontfix


Attachments

Description Serge Gautherie (:sgautherie) 2012-05-24 09:21:46 PDT
(In reply to Serge Gautherie (:sgautherie) from bug 758102 comment #2)
> {
> 97     this._tabbrowser.tabContainer.addEventListener(aType,
> 123       this._tabbrowser.removeEventListener(type, this._cleanup[type],
> true);
> }
> 
> See
> http://hg.mozilla.org/mozilla-central/rev/8ca8630b0c88
> 
> Is FF missing a '.tabContainer'?


(In reply to neil@parkwaycc.co.uk from bug 758102 comment #6)
> Sadly
> by the time the shutdown method runs, the binding no longer exists. I think
> the workaround might be to store the tabContainer in a property too, but
> :dao might have other ideas, after all he's going to have to fix the same
> bug ;-)
Comment 1 Dão Gottwald [:dao] 2012-05-31 11:43:04 PDT
bug 750454 will fix this
Comment 2 Serge Gautherie (:sgautherie) 2012-06-23 00:40:18 PDT
(In reply to Dão Gottwald [:dao] from comment #1)
> bug 750454 will fix this

It did in its
http://hg.mozilla.org/mozilla-central/rev/0a53a1ca7be0

V.Fixed
Comment 3 Serge Gautherie (:sgautherie) 2012-06-23 00:44:14 PDT
Branches would still like a fix for this very bug.
Comment 4 Justin Lebar (not reading bugmail) 2012-06-23 04:49:56 PDT
(In reply to Serge Gautherie (:sgautherie) from comment #3)
> Branches would still like a fix for this very bug.

The fix is unfortunately kind of large.  And since this code isn't well-tested, I wanted this to ride the trains.  Perhaps there's a way to write a smaller fix.

That said, I'm really surprised we haven't seen any regressions off the FUEL bug.  I'm worried that all of a sudden people will realize that that I broke their favorite add-on.
Comment 5 Serge Gautherie (:sgautherie) 2012-06-23 05:09:14 PDT
(In reply to Justin Lebar [:jlebar] from comment #4)
> Perhaps there's a way to write a smaller fix.

Per comment 0, I would expect a "one-liner" fix:
something similar to bug 758102 patch Dv1-SM211.
Comment 6 Justin Lebar (not reading bugmail) 2012-06-23 05:17:18 PDT
> Per comment 0, I would expect a "one-liner" fix

Oh, I'm sorry; I thought this was a different bug.

If this is shutdown-only code, why does it matter?

Note You need to log in before you can comment on or make changes to this bug.