Tumblr add-on (Add-ons SDK) creates zombie compartments

RESOLVED INVALID

Status

Tech Evangelism
Add-ons
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: jorgev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Steps to reproduce:

1) Authenticate with tumblr.
2) Visit a page (I used http://marvel.com/universe/Avengers)
3) Click on the toolbar button. I didn't post anything, I just looked around on the different tabs.
4) Close tab.

The end result is several zombie compartments in about:memory, even after the add-on is uninstalled.

This is their first release, so it was given preliminary approval only.
I can't reproduce this. After creating an account the first time, I briefly saw what looked like zombie compartments, but they disappeared after a short while and didn't come back. It's possible that they were legitimate compartments held alive by the iframe in the panel. With your STR, I get nothing.

Firefox 13.0.1, Linux
(Reporter)

Comment 2

6 years ago
Hmm, it looks like I can't reproduce this anymore either.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.