Last Comment Bug 758315 - Desktop GL implementation of glGetShaderPrecisionFormat should return precision 23, not 0
: Desktop GL implementation of glGetShaderPrecisionFormat should return precisi...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla15
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 11:55 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2012-05-25 08:30 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.00 KB, patch)
2012-05-24 11:55 PDT, Benoit Jacob [:bjacob] (mostly away)
jmuizelaar: review+
Details | Diff | Splinter Review

Description Benoit Jacob [:bjacob] (mostly away) 2012-05-24 11:55:36 PDT
Created attachment 626912 [details] [diff] [review]
patch

Because on desktop, we get plain floats which have 23-bit mantissa. 0 isn't an allowed value.
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2012-05-24 12:23:03 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/dfef2a45cc05

I swear that in my space-time reference frame, Jeff has already r+'d this patch.
Comment 2 Ed Morley [:emorley] 2012-05-25 08:30:33 PDT
https://hg.mozilla.org/mozilla-central/rev/dfef2a45cc05

Note You need to log in before you can comment on or make changes to this bug.