Hang in nvd3dum.dll@0x6cfe92 with 3D JPS plugin

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Other
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

({hang, regression})

unspecified
x86
Windows 7
hang, regression

Firefox Tracking Flags

(firefox13+ affected, firefox14-, firefox15- affected)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-f4975825-ec28-4702-a880-3639a2120524 .
============================================================= 

Prereq: 3D supported monitor and hardware

Steps:

1. Go to 3dvisionlive.com
2. Go to 3D photos
3. View Bloomberg01 --> Should see waiting to download image

Expected:

The image should appear in 3D.

Actual:

The waiting to download image appears, sits there for a period of time, but then I get a notification that a crash occurred with the plugin. Reloading the image does cause the image to appear in 3D.

Comment 1

6 years ago
(In reply to Jason Smith [:jsmith] from comment #0)
> Actual:
> 
> The waiting to download image appears, sits there for a period of time, but
> then I get a notification that a crash occurred with the plugin. Reloading
> the image does cause the image to appear in 3D.

What versions of Firefox are affected? Is this a new regression?
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #1)
> (In reply to Jason Smith [:jsmith] from comment #0)
> > Actual:
> > 
> > The waiting to download image appears, sits there for a period of time, but
> > then I get a notification that a crash occurred with the plugin. Reloading
> > the image does cause the image to appear in 3D.
> 
> What versions of Firefox are affected? Is this a new regression?

Definitely a new regression (didn't see this the last time we did 3D testing twice).
(Reporter)

Comment 3

6 years ago
Strangely enough now, can't reproduce now on Aurora 14 or Beta 13. Checked my about:crashes though, this crash did happen on beta:

https://crash-stats.mozilla.com/report/index/bp-8153a6f4-9c51-4b40-bf99-0e7972120524
status-firefox13: --- → affected
status-firefox15: --- → affected
(Reporter)

Comment 4

6 years ago
What's weirder is that the same STR to be used generate a second type of crash reports too for FF 15 and 13 respectively:

https://crash-stats.mozilla.com/report/index/d1be757c-cbfc-410a-96c4-02e9c2120524

https://crash-stats.mozilla.com/report/index/bp-db84e09e-50c5-4928-950f-66f152120524
Presumably this is related to/caused by the JPS plugin installed as part of the NVIDIA stereo support software.  Do the hangs/crashes disappear when that's disabled? What version of the NVIDIA driver suite do you have installed?  

(This is about all the help I can offer with this one, I don't know anything about this area.)

Comment 6

6 years ago
Tracking for FF13 through FF15, though I don't expect we'll be able to get this fix into FF13.
tracking-firefox13: ? → +
tracking-firefox14: ? → +
tracking-firefox15: --- → +

Comment 7

6 years ago
(In reply to Jason Smith [:jsmith] from comment #4)
> What's weirder is that the same STR to be used generate a second type of
> crash reports too for FF 15 and 13 respectively:
A plugin hang generates two crash reports, the browser side one which is common to many unrelated hangs (see bug 633253) and the plugin side one.

(In reply to Matthew Gregan [:kinetik] from comment #5)
> What version of the NVIDIA driver suite do you have installed?  
The crash report tells:
AdapterVendorID: 0x10de, AdapterDeviceID: 0x1040, AdapterSubsysID: 122219da, AdapterDriverVersion: 8.17.12.9610

There are few reports (only Jason's ones):
https://crash-stats.mozilla.com/report/list?signature=hang+|+NtUserChangeDisplaySettings+|+NtUserChangeDisplaySettings+|+nvd3dum.dll%400x6cfe92
Crash Signature: [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_SetWindow(mozilla::plugins::NPRemoteWindow const&)] → [@ hang | NtUserChangeDisplaySettings | NtUserChangeDisplaySettings | nvd3dum.dll@0x6cfe92]
Keywords: crash → hang
Summary: crash in hang [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_SetWindow(mozilla::plugins::NPRemoteWindow const&) ] → Hang in nvd3dum.dll@0x6cfe92 with 3D JPS plugin

Comment 8

6 years ago
Matthew - can you investigate further? This appears to be a recent regression, and reproducible.
Assignee: nobody → kinetik
Keywords: regressionwindow-wanted → regression
(In reply to Scoobidiver from comment #7)
> (In reply to Matthew Gregan [:kinetik] from comment #5)
> > What version of the NVIDIA driver suite do you have installed?  
> The crash report tells:
> AdapterDriverVersion: 8.17.12.9610

Unfortunately that version number is useless to me, since I have no idea how it maps to the public driver release numbers.

I can't reproduce it in a current nightly, nor in Firefox 13.  I'm testing with the NVIDIA 301.42 drivers; about:plugins shows a version number of 7.17.13.142 for the two NVISION plugins.
Assignee: kinetik → nobody
Keywords: regressionwindow-wanted
(In reply to Jason Smith [:jsmith] from comment #3)
> Strangely enough now, can't reproduce now on Aurora 14 or Beta 13. Checked
> my about:crashes though, this crash did happen on beta:
> 
> https://crash-stats.mozilla.com/report/index/bp-8153a6f4-9c51-4b40-bf99-
> 0e7972120524

Jason - can you help Matthew with reproducing issues around FF13? If there are none remaining, we should untrack.
Keywords: qawanted
(Reporter)

Updated

6 years ago
QA Contact: jsmith
Please try to get as specific of a regression range as possible - our final beta build is tomorrow, and at this point I'd only be comfortable with a backout (if we take any change).
(Reporter)

Comment 12

6 years ago
Confirmed that I cannot reproduce this on FF 14 Beta or Nightly. Closing as a worksforme.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted, regressionwindow-wanted
Resolution: --- → WORKSFORME

Updated

6 years ago
tracking-firefox14: + → -
tracking-firefox15: + → -
You need to log in before you can comment on or make changes to this bug.