Last Comment Bug 758381 - Build fail on MacOS X 10.7
: Build fail on MacOS X 10.7
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Hubert Figuiere [:hub]
:
Mentors:
Depends on:
Blocks: 661908
  Show dependency treegraph
 
Reported: 2012-05-24 14:12 PDT by Hubert Figuiere [:hub]
Modified: 2012-05-29 09:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Unbreak build on MacOS 10.7. r= (1.63 KB, patch)
2012-05-24 14:15 PDT, Hubert Figuiere [:hub]
ted: review+
Details | Diff | Review

Description Hubert Figuiere [:hub] 2012-05-24 14:12:59 PDT
Creating Python virtualenv
Traceback (most recent call last):
  File "/Users/hub/source/mozilla/mozilla-central/other-licenses/virtualenv/virtualenv.py", line 2270, in <module>
    main()
  File "/Users/hub/source/mozilla/mozilla-central/other-licenses/virtualenv/virtualenv.py", line 928, in main
    never_download=options.never_download)
  File "/Users/hub/source/mozilla/mozilla-central/other-licenses/virtualenv/virtualenv.py", line 1029, in create_environment
    site_packages=site_packages, clear=clear))
  File "/Users/hub/source/mozilla/mozilla-central/other-licenses/virtualenv/virtualenv.py", line 1155, in install_python
    fix_lib64(lib_dir)
  File "/Users/hub/source/mozilla/mozilla-central/other-licenses/virtualenv/virtualenv.py", line 1510, in fix_lib64
    if [p for p in distutils.sysconfig.get_config_vars().values()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/sysconfig.py", line 498, in get_config_vars
    func()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/sysconfig.py", line 407, in _init_posix
    raise DistutilsPlatformError(my_msg)
distutils.errors.DistutilsPlatformError: $MACOSX_DEPLOYMENT_TARGET mismatch: now "10.6" but "10.7" during configure
creating content/xbl/public/Makefile
can't read /Users/hub/source/mozilla/mozilla-central/content/xbl/public/Makefile.in: No such file or directory
creating dom/system/cocoa/Makefile
can't read /Users/hub/source/mozilla/mozilla-central/dom/system/cocoa/Makefile.in: No such file or directory



I talked to Ted about this bug.

Will attach the patch that work here.
Comment 1 Hubert Figuiere [:hub] 2012-05-24 14:15:25 PDT
Created attachment 626961 [details] [diff] [review]
Unbreak build on MacOS 10.7. r=
Comment 2 Hubert Figuiere [:hub] 2012-05-24 14:16:38 PDT
Comment on attachment 626961 [details] [diff] [review]
Unbreak build on MacOS 10.7. r=

Here is all the changes to pass on 10.7.

Not tested on TryServer yet
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-05-24 16:26:12 PDT
Comment on attachment 626961 [details] [diff] [review]
Unbreak build on MacOS 10.7. r=

Review of attachment 626961 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry, I don't have 10.7 here yet to test with. This looks fine.
Comment 5 Ed Morley [:emorley] 2012-05-25 08:24:26 PDT
https://hg.mozilla.org/mozilla-central/rev/c9239be4261f

Note You need to log in before you can comment on or make changes to this bug.