Last Comment Bug 758413 - Move of jpeg to gkmedia breaks anything using JPEG_LIBS (which now refers to a library we don't build)
: Move of jpeg to gkmedia breaks anything using JPEG_LIBS (which now refers to ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Other Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: :Ehsan Akhgari (out sick)
:
Mentors:
Depends on: 750867
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 15:16 PDT by [:jesup] on pto until 2016/7/5 Randell Jesup
Modified: 2012-06-09 19:16 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (671 bytes, patch)
2012-05-24 15:23 PDT, :Ehsan Akhgari (out sick)
ted: review+
Details | Diff | Review

Description [:jesup] on pto until 2016/7/5 Randell Jesup 2012-05-24 15:16:44 PDT
Bug 750867 changed the library name of jpeg for windows, but missed one use of the old name in configure.in.

The old name was jpeg3250.lib, the new one is mozjpeg.lib (on non-windows I think it's always mozjpeg.lib)

See in configure.in (for mingw only):

   MOZ_JPEG_LIBS='$(call EXPAND_LIBNAME_PATH,jpeg32$(VERSION_NUMBER),$(DEPTH)/media/libjpeg)'

This should be removed I think and just leave the default mozjpeg value.  (Running check build now)

This showed up because webrtc used JPEG_LIBS in a makefile, and it had the old name.
Comment 1 :Ehsan Akhgari (out sick) 2012-05-24 15:23:29 PDT
Created attachment 626992 [details] [diff] [review]
Patch (v1)

The same goes for MOZ_PNG_LIBS I think.
Comment 2 Mike Hommey [:glandium] 2012-05-24 22:20:10 PDT
(In reply to Randell Jesup [:jesup] from comment #0)
> This showed up because webrtc used JPEG_LIBS in a makefile, and it had the
> old name.

And that works ? Because if you include jpeg libs twice (once in webrtc and then once in gkmedia), that should break.
Comment 3 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-05-24 22:39:28 PDT
It appears to work, but I'll be removing webrtc's JPEG_LIBS mod from gkmedia (it was added to the gkmedia link because webrtc uses jpeg, but at the time jpeg was in xul, so we had to live with a second copy, at least temporarily).  It was on the list to find a way to avoid duplicate copies, but with jpeg in gkmedia that's no longer an issue.  We've spent a LOT of time dealing with fallout of the gkmedia split...
Comment 4 :Ehsan Akhgari (out sick) 2012-06-08 12:48:56 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b50468e9c210
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-06-09 19:16:03 PDT
https://hg.mozilla.org/mozilla-central/rev/b50468e9c210

Note You need to log in before you can comment on or make changes to this bug.