Closed Bug 758425 Opened 8 years ago Closed 8 years ago

Re-work B2g opt gecko builds, add debug

Categories

(Release Engineering :: General, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philikon, Assigned: bhearsum)

References

Details

Attachments

(4 files, 1 obsolete file)

Turns out that B2G debug builds were busted and nobody really noticed. Can we get debug builds for B2G as well please?
Depends on: 758093
This patch should be landed now that https://hg.mozilla.org/mozilla-central/rev/bd4201e13a9f is landed.  By landing this patch before the b2g-debug platform is created, the debug mozconfig name can be reclaimed.
Assignee: nobody → catlee
Priority: -- → P2
Attachment #627048 - Flags: review?(armenzg)
Attachment #627048 - Flags: review?(armenzg) → review+
I'm taking over on this while Chris is on PTO.
Assignee: catlee → nobody
Component: Release Engineering → Release Engineering: Automation (General)
QA Contact: release → catlee
Assignee: nobody → bhearsum
Michael, these use the new platform names we talked about yesterday. I couldn't find an example of a debug b2g mozconfig so I simply swapped --enable-profiling for --enable-debug.
Attachment #627048 - Attachment is obsolete: true
Attachment #635286 - Flags: review?(mwu)
Oh, I should note that the plan here is to enable new opt+debug in parallel with the ones that jhford originally set-up. Once we validate the new ones, we'll shut those off and remove the mozconfigs.
Comment on attachment 635286 [details] [diff] [review]
opt and debug mozconfigs using new platform names

Not quite a realistic build yet, but adding debug builds can only help.

r=me with s/arm7a/armv7a/
Attachment #635286 - Flags: review?(mwu) → review+
Comment on attachment 635286 [details] [diff] [review]
opt and debug mozconfigs using new platform names

Changed to armv7a, landed: http://hg.mozilla.org/mozilla-central/rev/e6f8693c02c6
Attachment #635286 - Flags: checked-in+
A few things here:
* Add gb_armv7a_gecko as a supported platform
* Enable prefixes for scheduler names
* Ifdef some things so we don't need to specify them in b2g_config.py
Attachment #635753 - Flags: review?(rail)
Attachment #635753 - Flags: review?(rail) → review+
One big caveat here: I don't think try chooser works with it at all - I was getting builds with every single try push in staging.

Here's a summary of what's happening here:
* Creating b2g_config.py plus the production, preproduction, and staging localconfigs. These are done similarly to the Thunderbird ones in that they import a lot from config and the base localconfigs, and override where needed.
* Project branches aren't supported yet. I tried enabled them yesterday but hit a lot of issues. We'll do that in a follow-up.
* Fix the change source deduplication in universal_master_sqlite.cfg and builder_master.cfg -- it was removing the real mozilla-central poller because it only compared .branch (rather than using the object's __cmp__, which compares more than that).

After landing, this will enable opt + debug builds of gingerbread based armv7a gecko on mozilla-central, inbound, and try. The original opt builds that jhford set-up will remain enabled for now. I spoke with edmorley about TBPL, and he said that we shouldn't need to do anything there to get the debug builds showing up. I'll verify that after landing.

In follow-ups, we should:
* Make project branches work with b2g_config.py
* Disable/get rid of hacks for the original builds that jhford set-up
* Enable other build types
Attachment #635761 - Flags: review?(rail)
Attachment #635761 - Flags: review?(rail) → review+
Comment on attachment 635753 [details] [diff] [review]
buildbotcustom support for separated b2g builds

http://hg.mozilla.org/build/buildbotcustom/rev/f18daf293de4
Attachment #635753 - Flags: checked-in+
Comment on attachment 635761 [details] [diff] [review]
create separated b2g configs, enable opt+debug on central, inbound, try

http://hg.mozilla.org/build/buildbot-configs/rev/6025e60fa153
Attachment #635761 - Flags: checked-in+
FTR, I used the attached patch to add/fix b2g symlinks.
 python manage_masters.py -f production-masters.json -R build -j8 b2g_links
 python manage_masters.py -f production-masters.json -R try -j8 b2g_links
 python manage_masters.py -f production-masters.json -R scheduler -j8 b2g_links
In production 2012-06-22 09:30 PT
Updating summary to match what we've actually done here.
Summary: Build B2G in debug mode as well → Re-work B2g opt gecko builds, add debug
Depends on: 767473
Depends on: 767507
Depends on: 767522
https://bugzilla.mozilla.org/show_bug.cgi?id=767528 will be tracking turning off the old-style b2g builds, and will probably happen sometime next week.
This is done now. Builds are enabled and showing on TBPL. Some minor-ish follow-up work to be done in: bug 767515, bug 767501, bug 767503, and bug 767528.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.