Closed Bug 758458 Opened 9 years ago Closed 8 years ago

Favicon's with multiple resolutions should use 32x32 version

Categories

(Firefox for Android Graveyard :: General, defect)

Other
Android
defect
Not set
normal

Tracking

(fennec+)

RESOLVED DUPLICATE of bug 748100
Tracking Status
fennec + ---

People

(Reporter: rehandalal+mozilla, Assigned: ckitching)

Details

ICO files store multiple images. Fennec should check for a 32x32 sized image in the ICO file and use it, if available. Currently it uses the 16x16 image even when a higher resolution image exists in the file.
Severity: trivial → normal
tracking-fennec: --- → ?
I bet this is why most Favicons look like garbage in Fennec, no?
Since we load and show favicons in Java/Android, we depend on the Android utilities to handle ICOs. THose utilities don't handle multiple bitmaps in an ICO file, so we get the first one it finds. Supporting multiple bitmaps would require new code, or loading via Gecko somehow.
(In reply to Mark Finkle (:mfinkle) from comment #2)
> Supporting multiple bitmaps
> would require new code, or loading via Gecko somehow.

Gecko doesn't handle this. See bug 419588.
tracking-fennec: ? → +
This bug describes the same problem as Bug 748100 - the need for a Java solution to decode ICO files (With, in this case, emphasis on extracting the most resolute image therefrom). (Fixed by the same patch, as well)
I think this means close-as-duplicate time, then?
Assignee: nobody → ckitching
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: ICODecoder
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.