New but read messages are ignored by message filters in Thunderbird

RESOLVED DUPLICATE of bug 308148

Status

defect
RESOLVED DUPLICATE of bug 308148
7 years ago
2 years ago

People

(Reporter: David-peters, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Created a filter that copies all messages from the IMAP inbox to a local mail folder in Thunderbird


Actual results:

When Thunderbird is started, only unread messages are copied by the filter. Messages that are new to Thunderbird but read elsewhere already (on the IMAP web interface, on the smartphone etc.) are not filtered and not copied by Thunderbird.


Expected results:

When Thunderbird is started, all messages that are new to Thunderbird should be detected, handled and copied by the filter. Messages that are new to Thunderbird but read elsewhere already (on the IMAP web interface, on the smartphone etc.) should be filtered and copied by Thunderbird as well.

Comment 1

7 years ago
(In reply to David.P from comment #0)
I created a filter which moves a message from IMAP to local folder and it works, and the message moved was already read.

User Agent: Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20120428 Thunderbird/12.0.1
Application Build ID: 20120428123100
Reporter

Comment 2

7 years ago
(In reply to Hashem Masoud from comment #1)

> I created a filter which moves a message from IMAP to local folder and it
> works, and the message moved was already read.

Are you sure that your filter was run *automatically* and not manually? (If manually run, such a filter actually DOES move read messages, but not if run automatically.) To my knowledge, you would be the first on the entire Web who manages to move read messages by an automatic filter. 

See also discussion here
http://forums.mozillazine.org/viewtopic.php?f=39&t=2461817
... where it is claimed that this (the present bug) is "intended behavior"...

Can you check this (whether your filter DOES actually move read messages automatically), and post a screenshot of your filter settings?

This is my filter (that does not work if invoked automatically, only if run manually):
http://666kb.com/i/c48au3uah3kuc6bfg.png

Comment 3

7 years ago
(In reply to David.P from comment #2)
Yes it was manually run.

Comment 4

7 years ago
Rkent, can you explain if this is intended behaviour?
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: unspecified → 12

Comment 5

7 years ago
BTW nice that somebody is using my "Mark as Unread" filter action :)
David.P could you find out why it is not translated in your German TB version? Did the localizers just not have the time yet, or did I implement it by mistake so that it can't be translated?

Comment 6

7 years ago
hi aceman, hi Hashem Masoud ,

I think you misunderstood DavidP..

I have the same problem. I have a imap account and it is working on TB 13.0.1. I create a filter where massages they are read and older then 2 days are moved to a temporary archive. This filter is working manually. And now the special thing. It works also automaticly. But only one time and only when you set the filter functionality for the first time. So once you have create a filter and run these filter again, no read-marked mails where detected. Maybe also all other "states" are not working. When I do this with a new profile I can reproduce this. Also with different mails.
In the passed I use this filters also with older TB releases. The problems start the first time with an update. I think it was up from the Update from Version 12 to 13. I have also checked this problem in the safe-mode. It is still there.

Comment 7

6 years ago
(In reply to David.P from comment #0)

Assuming "When Thunderbird is started" means  "generally when Thunderbird gets new mails from server": Same problem here with TB 17.0.5 on x86_64 Windows 7 which is very uncomfortable when reading mails with smartphone before downloading them with TB. Hope this gets fixed (respectively behaviour intention changes) soon... Many thanks to the assigned developer!

Comment 8

6 years ago
I doubt this problem is as unusual as you think. As with Herbert, it started for me with an update, fairly recently. When I read my messages elsewhere and then opened Thunderbird on my main computer, "Run Filters on Folder" used to work, even for read messages. Now, it does nothing. It's a real drag, as I have to manually move all of my messages into their appropriate folders. Hope you can figure out a fix soon! Thanks.

Comment 9

6 years ago
Aryx, could you please check out comment 5?

Comment 10

6 years ago
(In reply to :aceman from comment #4)
> Rkent, can you explain if this is intended behaviour?
Flags: needinfo?(kent)

Comment 11

6 years ago
PS -- I can get the emails into their correct folders by manually selecting all of the messages in my Inbox that have filters, and using "Run Filters on Message."
This bug from my perspective is accumulated a number of unrelated issues.

I'll take as canonical comment 0:

"Actual results: When Thunderbird is started, only unread messages are copied by the filter. Messages that are new to Thunderbird but read elsewhere already (on the IMAP web interface, on the smartphone etc.) are not filtered and not copied by Thunderbird."

This is currently by design. I don't particularly like this design, but Bienvenu explained once that they had issues with other methods of detecting messages needing filtering.

Re comment 8: My patch for bug 695671 should fix some issues on Run Filters on Folder, don't know about your issue.

On a related issue, my patch to implement periodic filters (bug 864187) will allow at least an automatic workaround for the unread messages problem - but I have been waiting for 2 months for a review of that and bug 695671 so I am starting to lose hope that we can get this into TB 24.
Flags: needinfo?(kent)

Comment 13

6 years ago
Dear all, I created an account here specifically to raise awareness for this bug. 

The statement that this behaviour is "by design" misses the point(s):
- there is no reason for this to work as it does now;
- it makes the filter condition "apply to read mail" useless, and;
- it makes the filter condition "apply to unread mail" redundant;
- people are proposing work arounds.

"If it looks like a duck ..."  BTW, even the Wikipedia entry for "Software bug" states explicitly that a design can also contain bugs: http://en.wikipedia.org/wiki/Software_bug

I'd love to be able to fix this myself, but I don't have the skills to do so. So, please, pretty please someone fix this?

Comment 14

6 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=566873

This is a stupid, frustrating bug.  I wish this would get fixed.  This is a duplicate to my thread above.  Please vote that one up and maybe devs will quit ignoring it.

Comment 15

5 years ago
Same Problem here :-(
I cannot believe it is still unconfirmed?!
Please fix it!!!

Comment 16

5 years ago
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.4.0
Same problem here.

Comment 17

5 years ago
(In reply to Kent James (:rkent) from comment #12)
> 
> This is currently by design. I don't particularly like this design, but
> Bienvenu explained once that they had issues with other methods of detecting
> messages needing filtering.

There is no obvious reason why the method of detection if a message needs filtering is depending on the read flag. At least from the external perspective of a fairly experienced user. Additionally, if this behaviour is by design, it isn´t mentioned in the setup dialog or made clear to the user otherwise.

In today´s email world it becomes the regular case that one can access his/her mails from multiple devices, and so the read flag should only be used for human information, not for program logic at all. Its just a flag.

Comment 18

5 years ago
I agree. It's a frustrating bug.
This is also described earlier by bug 308148.

The issue is well understood, so please only comment there if you intend to supply the patch to fix it.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 308148

Comment 20

2 years ago
Just to clarify - this bug is resolved because bug 308148 (a duplicate) is resolved. That bug-fix has a "hidden" option to enable filtration of read messages, one must use this plug-in to enable this feature: https://addons.mozilla.org/en-US/thunderbird/addon/extendimapfilters/ (or directly edit some preferences file on disk). Nasty, but should work.
You need to log in before you can comment on or make changes to this bug.