Last Comment Bug 758583 - "ERROR: Potential deadlock detected" with mozCaptureStreamUntilEnded
: "ERROR: Potential deadlock detected" with mozCaptureStreamUntilEnded
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: mozilla15
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 326633 664918
  Show dependency treegraph
 
Reported: 2012-05-25 05:21 PDT by Jesse Ruderman
Modified: 2012-05-30 08:18 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (assumes it is on jesse's computer) (225 bytes, text/html)
2012-05-25 05:21 PDT, Jesse Ruderman
no flags Details
fix (1.56 KB, patch)
2012-05-28 20:55 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
rjesup: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2012-05-25 05:21:32 PDT
Created attachment 627194 [details]
testcase (assumes it is on jesse's computer)

1. Save the testcase.
2. Fix the path to point at your tree.
3. Load [your copy of the testcase] in a debug build of Firefox.
4. Quit Firefox with Cmd+Q.

Result: Deadlock assertions.


###!!! ERROR: Potential deadlock detected:
$ @@@ ###!!! ERROR: Potential deadlock detected:
=== Cyclical dependency starts at
--- Mutex : mozilla::media::SourceMediaStream calling context
stacks_disabled+0[stacks_disabled +0x0]

--- Next dependency:
--- Mutex : MediaStreamGraphImpl (currently acquired)
 calling context
stacks_disabled+0[stacks_disabled +0x0]

=== Cycle completed at
--- Mutex : mozilla::media::SourceMediaStream calling context
stacks_disabled+0[stacks_disabled +0x0]

Deadlock may happen for some other execution

###!!! ASSERTION: Potential deadlock detected:
$ @@@ ###!!! ASSERTION: Potential deadlock detected:
Cyclical dependency starts at
Mutex : mozilla::media::SourceMediaStream
Next dependency:
Mutex : MediaStreamGraphImpl (currently acquired)
Cycle completed at
Mutex : mozilla::media::SourceMediaStream
Deadlock may happen for some other execution

: 'Error', file BlockingResourceBase.cpp, line 128
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-28 20:55:15 PDT
Created attachment 627840 [details] [diff] [review]
fix

Not sure how to test this since it requires shutting down Firefox...
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-29 02:11:52 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/cfd001299d34
Comment 3 Ed Morley [:emorley] 2012-05-30 08:18:52 PDT
https://hg.mozilla.org/mozilla-central/rev/cfd001299d34

Note You need to log in before you can comment on or make changes to this bug.