Last Comment Bug 758644 - Contents/CodeResources isn't included in MARs
: Contents/CodeResources isn't included in MARs
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Ben Hearsum (:bhearsum)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 08:23 PDT by Ben Hearsum (:bhearsum)
Modified: 2012-09-13 16:16 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
copy CodeResources after signing (2.40 KB, patch)
2012-05-28 13:37 PDT, Ben Hearsum (:bhearsum)
ted: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
akeybl: approval‑mozilla‑esr10-
bhearsum: checkin+
Details | Diff | Splinter Review

Description Ben Hearsum (:bhearsum) 2012-05-25 08:23:50 PDT
This file is a symlink that points to _CodeSignature/CodeResources. After landing bug 723176 and updating from an unsigned build to a signed build, this file wasn't present despite it being in the dmg. I looked at the complete MAR directly and it wasn't there either. I think that the update generation code doesn't what to do with symlinks or something.
Comment 1 Ben Hearsum (:bhearsum) 2012-05-28 13:37:40 PDT
Created attachment 627777 [details] [diff] [review]
copy CodeResources after signing

I tried this without the 'rm' first, and found that OS X created a symlink to _CodeSignature/CodeResources. Couldn't find a way to make cp overwrite it because it was "the same file".
Comment 2 Ben Hearsum (:bhearsum) 2012-06-11 08:13:56 PDT
Comment on attachment 627777 [details] [diff] [review]
copy CodeResources after signing

http://hg.mozilla.org/mozilla-central/rev/6aab5d7f2cc7
Comment 3 Ben Hearsum (:bhearsum) 2012-06-11 13:12:14 PDT
Landed cleanly.
Comment 4 Ben Hearsum (:bhearsum) 2012-06-11 13:13:53 PDT
Comment on attachment 627777 [details] [diff] [review]
copy CodeResources after signing

This patch ensures consistency between the two possible CodeResources files in .app bundles. It should let 'codesign -vv' pass on more platforms. It's not critical, but low risk and nice to have.
Comment 5 Alex Keybl [:akeybl] 2012-06-14 09:52:38 PDT
Comment on attachment 627777 [details] [diff] [review]
copy CodeResources after signing

[Triage Comment]
Approving for Aurora/Beta, but we should wait to see if this is necessary on the ESR (depends on whether we end up signing that branch).
Comment 7 Nick Thomas [:nthomas] 2012-08-28 16:48:23 PDT
Standard8, does Thunderbird have somewhere this change should be ported to ? My partial update from 14.0 to 15.0 failed on Mac 10.6.8 with this in the last-update.log:
...
PREPARE PATCH Contents/Info.plist
PREPARE PATCH Contents/CodeResources
PREPARE ADD Contents/MacOS/update-settings.ini
EXECUTE ADD precomplete
EXECUTE PATCH Contents/_CodeSignature/CodeResources
unable to open destination file: Contents/_CodeSignature/CodeResources, err: 2
### execution failed
...
Comment 8 Nick Thomas [:nthomas] 2012-08-28 16:52:56 PDT
Perhaps that's a red herring, I have
 Contents/CodeResources
 Contents/_CodeSignature/CodeResources
which are both files, and identical. And applying the partial works fine if I reset the update process and make sure I don't have any terminals open in the .app.
Comment 9 Mark Banner (:standard8) 2012-08-28 23:53:27 PDT
(In reply to Nick Thomas [:nthomas] from comment #7)
> Standard8, does Thunderbird have somewhere this change should be ported to ?

Just to answer the question anyway, this code is in toolkit, so we'll pick it up by default anyway.
Comment 10 Alex Keybl [:akeybl] 2012-09-13 16:16:52 PDT
Comment on attachment 627777 [details] [diff] [review]
copy CodeResources after signing

Waiting for ESR17 to roll this out.

Note You need to log in before you can comment on or make changes to this bug.