Flash plugins on 5/25/2012 Nightly crash on Gingerbread

VERIFIED FIXED in Firefox 15

Status

()

defect
P1
critical
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: snorp, Assigned: glandium)

Tracking

({crash, regression})

15 Branch
Firefox 15
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 unaffected, firefox15 verified, firefox16 verified, firefox17 verified)

Details

(Whiteboard: [native-crash], crash signature)

The stack trace looks like this:

Program received signal SIGSEGV, Segmentation fault.
warning: .dynamic section for "/Users/snorp/moz-gdb/lib/HT04KHJ05698/system/lib/libflashplayer.so" is not at the expected address (wrong library or version mismatch?)
0xafd16104 in __libc_android_abort () from /Users/snorp/moz-gdb/lib/HT04KHJ05698/system/lib/libc.so
(gdb) bt
#0  0xafd16104 in __libc_android_abort () from /Users/snorp/moz-gdb/lib/HT04KHJ05698/system/lib/libc.so
#1  0xafd13b5c in dlfree () from /Users/snorp/moz-gdb/lib/HT04KHJ05698/system/lib/libc.so
#2  0xafd149b0 in free () from /Users/snorp/moz-gdb/lib/HT04KHJ05698/system/lib/libc.so
#3  0xafc009c6 in operator delete(void*) () from /Users/snorp/moz-gdb/lib/HT04KHJ05698/system/lib/libstdc++.so
#4  0x72c143c2 in SkDevice::~SkDevice (this=0x4c780880, __in_chrg=<optimized out>)
    at /Users/snorp/source/mozilla-central/gfx/skia/src/core/SkDevice.cpp:35
#5  0x72bfd368 in SkRefCnt::unref (this=0x4c780880) at ../../dist/include/skia/SkRefCnt.h:60
#6  0x72c0f428 in DeviceCM::~DeviceCM (this=0x47559880, __in_chrg=<optimized out>)
    at /Users/snorp/source/mozilla-central/gfx/skia/src/core/SkCanvas.cpp:89
#7  0x72c108de in SkCanvas::internalRestore (this=0x361168) at /Users/snorp/source/mozilla-central/gfx/skia/src/core/SkCanvas.cpp:814
#8  0x72c10910 in SkCanvas::~SkCanvas (this=0x361168, __in_chrg=<optimized out>) at /Users/snorp/source/mozilla-central/gfx/skia/src/core/SkCanvas.cpp:449
#9  0x72c1093c in SkCanvas::~SkCanvas (this=0x361168, __in_chrg=<optimized out>) at /Users/snorp/source/mozilla-central/gfx/skia/src/core/SkCanvas.cpp:454
#10 0x72a578aa in unref (this=<optimized out>) at /Users/snorp/source/mozilla-central/gfx/skia/include/core/SkRefCnt.h:60
#11 ~ANPCanvas (this=<optimized out>, __in_chrg=<optimized out>) at /Users/snorp/source/mozilla-central/other-licenses/skia-npapi/SkANP.h:63
#12 anp_deleteCanvas (canvas=0x361118) at /Users/snorp/source/mozilla-central/other-licenses/skia-npapi/ANPCanvas.cpp:35
#13 0x8153adc6 in ?? () from /Users/snorp/moz-gdb/lib/HT04KHJ05698/system/lib/libflashplayer.so
#14 0x8153adc6 in ?? () from /Users/snorp/moz-gdb/lib/HT04KHJ05698/system/lib/libflashplayer.so

Regression range 831ff2eb9a28 to 3871d6ca5fb2
It looks like bug 746794 is the likely culprit. Testing a backout locally.
Backing out bug 746794 locally did fix the issue for me. Mike can you take care of backing that out?
Assignee: snorp → mh+mozilla
Assignee

Comment 4

7 years ago
https://hg.mozilla.org/mozilla-central/rev/034bbdc7b9c9
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15

Updated

7 years ago
Blocks: 746794
Severity: normal → critical
Keywords: crash, regression
Whiteboard: [native-crash]
Version: Trunk → Firefox 15

Updated

7 years ago
Crash Signature: [@ __libc_android_abort | dlfree | free | SkDevice::~SkDevice] [@ dlfree | free | SkDevice::~SkDevice]

Updated

7 years ago
Crash Signature: [@ __libc_android_abort | dlfree | free | SkDevice::~SkDevice] [@ dlfree | free | SkDevice::~SkDevice] → [@ __libc_android_abort | dlfree | free | SkDevice::~SkDevice] [@ __libc_android_abort | dlfree | calloc | SkDevice::~SkDevice] [@ dlfree | free | SkDevice::~SkDevice] [@ SkDevice::~SkDevice]
WFM via HTC Nexus One (2.3.4) across the board, latest-flash install
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.