Last Comment Bug 758748 - Cannot build in toolkit/xre any more!
: Cannot build in toolkit/xre any more!
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Joey Armstrong [:joey]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 12:52 PDT by :Ehsan Akhgari
Modified: 2012-05-26 05:33 PDT (History)
6 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
change SOURCE_REPO var check from error to warn. (1.24 KB, patch)
2012-05-25 13:41 PDT, Joey Armstrong [:joey]
khuey: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2012-05-25 12:52:08 PDT
$ make -C obj-ff-dbg/toolkit/xre
Makefile:230: *** Variable SOURCE_REPO does not contain a value.  Stop.

Gerv, has this been caused by your recent changes?
Comment 1 Joey Armstrong [:joey] 2012-05-25 13:08:24 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #0)
> $ make -C obj-ff-dbg/toolkit/xre
> Makefile:230: *** Variable SOURCE_REPO does not contain a value.  Stop.
> 
> Gerv, has this been caused by your recent changes?

Are you building within an hg sandbox ?  The error will be reported if 'hg showconfig' cannot obtain a value for $SOURCE_REPO (~line 264 in toolkit/xre/Makefile.in)
Comment 2 Justin Wood (:Callek) 2012-05-25 13:09:51 PDT
Joey, didn't we decide the goal was *NOT* to break local devs with your changes there.

And that if it did break local devs something was severely wrong and it needed redesign/backout?
Comment 3 Joey Armstrong [:joey] 2012-05-25 13:30:32 PDT
(In reply to Justin Wood (:Callek) from comment #2)
> Joey, didn't we decide the goal was *NOT* to break local devs with your
> changes there.
> 
> And that if it did break local devs something was severely wrong and it
> needed redesign/backout?

Similar content but I think this check/patch pre-dates that discussion.  Another bug is open for collecting revision control commands into a central include file and it was discussed there.

This is easy enough to revert or make conditional for o-fficial builds.
Comment 4 Joey Armstrong [:joey] 2012-05-25 13:41:14 PDT
Created attachment 627344 [details] [diff] [review]
change SOURCE_REPO var check from error to warn.
Comment 5 Joey Armstrong [:joey] 2012-05-25 13:43:46 PDT
Comment on attachment 627344 [details] [diff] [review]
change SOURCE_REPO var check from error to warn.

Chaser job for bug # 688061
Morph SOURCE_REPO variable test from error to warn so building within a non-hg sandbox will not force failure.
Comment 6 :Ehsan Akhgari 2012-05-25 14:04:38 PDT
(In reply to Joey Armstrong [:joey] from comment #1)
> (In reply to Ehsan Akhgari [:ehsan] from comment #0)
> > $ make -C obj-ff-dbg/toolkit/xre
> > Makefile:230: *** Variable SOURCE_REPO does not contain a value.  Stop.
> > 
> > Gerv, has this been caused by your recent changes?
> 
> Are you building within an hg sandbox ?  The error will be reported if 'hg
> showconfig' cannot obtain a value for $SOURCE_REPO (~line 264 in
> toolkit/xre/Makefile.in)

I don't know what an hg sandbox is.  I use git, FWIW.  :-)
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-05-25 14:06:11 PDT
He means an hg checkout. :-)
Comment 8 :Ehsan Akhgari 2012-05-25 14:10:54 PDT
Well, then, no.  hg is not involved at all in my build process.
Comment 9 Joey Armstrong [:joey] 2012-05-25 15:54:51 PDT
https://tbpl.mozilla.org/?tree=Try&rev=f4c6d3d41a94
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-05-26 05:33:22 PDT
https://hg.mozilla.org/mozilla-central/rev/728450b22631

Note You need to log in before you can comment on or make changes to this bug.