Closed Bug 758835 Opened 8 years ago Closed 6 years ago

Add ability to flag tests as expected failures in the manifest

Categories

(Testing :: Marionette, defect)

defect
Not set

Tracking

(firefox27 fixed, b2g-v1.2 fixed)

RESOLVED FIXED
mozilla27
Tracking Status
firefox27 --- fixed
b2g-v1.2 --- fixed

People

(Reporter: jgriffin, Assigned: jgriffin)

References

Details

Attachments

(1 file)

We should support an expectedfailure = true flag in the test manifest, which would cause the flagged test to be run as an expected failure, i.e., to fail if the test passes.

This would be the exact analog to the @unittest.expectedFailure decorator that is available to Python tests.
Whoops, wrong component.
Component: Mochitest → Marionette
QA Contact: mochitest → marionette
Assignee: nobody → jgriffin
Works well locally; will run through try shortly.
Attachment #818159 - Flags: review?(dburns)
Comment on attachment 818159 [details] [diff] [review]
Add ability to mark tests as expected failures in the manifest,

Review of attachment 818159 [details] [diff] [review]:
-----------------------------------------------------------------

looks good
Attachment #818159 - Flags: review?(dburns) → review+
https://hg.mozilla.org/mozilla-central/rev/91993a2ea998
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 884528
You need to log in before you can comment on or make changes to this bug.