Closed Bug 758851 Opened 9 years ago Closed 9 years ago

crash in nsDocAccessible::GetEditor

Categories

(Core :: Disability Access APIs, defect)

15 Branch
x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 758713
Tracking Status
firefox15 - ---

People

(Reporter: scoobidiver, Assigned: hub)

Details

(Keywords: crash, regression, topcrash)

Crash Data

It first appeared in 15.0a1/20120525062919. The regression range might be (with several builds per day, debug symbols are sometimes missing):
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f43e8d300f21&tochange=caea66e968bf

Signature 	nsDocAccessible::GetEditor More Reports Search
UUID	89ddd9e8-4568-4731-b34c-b2bb22120525
Date Processed	2012-05-25 20:55:49
Uptime	521
Last Crash	3.7 days before submission
Install Age	8.7 minutes since version was first installed.
Install Time	2012-05-25 20:46:31
Product	Firefox
Version	15.0a1
Build ID	20120525062919
Release Channel	nightly
OS	Mac OS X
OS Version	10.7.3 11D50b
Build Architecture	amd64
Build Architecture Info	family 6 model 23 stepping 10
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0x28
User Comments	Had just typed "adafruit.com" into the address bar and hit enter after hitting "back" from a Google ad.
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x 8a0GL Context? GL Context+ GL Layers? GL Layers+ 
Obj-C Exception data:
NSInternalInconsistencyException: trying to set focus to ignored element! ((0x1098f4910) AXUnknown)
EMCheckCompatibility	True

Frame 	Module 	Signature 	Source
0 	XUL 	nsDocAccessible::GetEditor 	nsDocAccessible.cpp:533
1 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
2 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
3 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
4 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
5 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
6 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
7 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
8 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
9 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
10 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
11 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
12 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
13 	XUL 	nsHyperTextAccessible::GetEditor 	nsHyperTextAccessible.cpp:1499
14 	XUL 	nsHyperTextAccessible::NativeState 	nsHyperTextAccessible.cpp:134
15 	XUL 	nsAccessibleWrap::GetNativeType 	nsAccessibleWrap.h:63
16 	XUL 	nsAccessibleWrap::GetNativeObject 	nsAccessibleWrap.mm:36
17 	XUL 	nsAccessibleWrap::IsIgnored 	nsAccessibleWrap.mm:223
18 	XUL 	nsAccessibleWrap::GetUnignoredParent 	nsAccessibleWrap.mm:256
19 	XUL 	-[mozAccessible parent] 	mozAccessible.mm:311
20 	XUL 	-[mozAccessible expire] 	mozAccessible.mm:639
21 	XUL 	nsAccessibleWrap::Shutdown 	nsAccessibleWrap.mm:120
22 	XUL 	ClearCacheEntry<nsAccessible> 	nsAccCache.h:26
23 	XUL 	PL_DHashTableEnumerate 	pldhash.cpp:715
24 	XUL 	nsDocAccessible::Shutdown 	nsBaseHashtable.h:223
25 	XUL 	nsAccDocManager::HandleEvent 	nsAccDocManager.cpp:282
26 	XUL 	nsEventListenerManager::HandleEventInternal 	nsEventListenerManager.cpp:809
27 	XUL 	nsEventTargetChainItem::HandleEventTargetChain 	nsEventListenerManager.h:137
28 	XUL 	nsEventDispatcher::Dispatch 	nsEventDispatcher.cpp:643
29 	XUL 	nsEventDispatcher::DispatchDOMEvent 	nsEventDispatcher.cpp:706
30 	XUL 	nsDocument::DispatchPageTransition 	nsDocument.cpp:7264
31 	XUL 	nsDocument::OnPageHide 	nsDocument.cpp:7375
32 	XUL 	DocumentViewerImpl::PageHide 	nsDocumentViewer.cpp:1253
33 	XUL 	nsDocShell::FirePageHideNotification 	nsDocShell.cpp:1582
34 	XUL 	nsDocShell::CreateContentViewer 	nsDocShell.cpp:7461
35 	XUL 	nsDSURIContentListener::DoContent 	nsDSURIContentListener.cpp:132
36 	XUL 	nsDocumentOpenInfo::TryContentListener 	nsURILoader.cpp:677
37 	XUL 	nsDocumentOpenInfo::DispatchContent 	nsURILoader.cpp:374
38 	XUL 	nsDocumentOpenInfo::OnStartRequest 	nsURILoader.cpp:262
39 	XUL 	nsHttpChannel::CallOnStartRequest 	nsHttpChannel.cpp:766 
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsDocAccessible%3A%3AGetEditor
Crash Signature: [@ nsDocAccessible::GetEditor] → [@ nsDocAccessible::GetEditor ]
isn't that bug 758713 as well?
It's #2 top crasher in today's build.
Keywords: topcrash
(In reply to Hub Figuiere [:hub] from comment #1)
> isn't that bug 758713 as well?

yes, you create an accessible tree during accessible tree desctruction
Assignee: nobody → hub
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 758713
You need to log in before you can comment on or make changes to this bug.