Closed Bug 758895 Opened 8 years ago Closed 8 years ago

crash in libxul.so@0xe41046

Categories

(Firefox for Android :: General, defect)

15 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mcepl, Unassigned)

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-a58b7354-cac8-4314-be7a-b50292120523 .
============================================================= 
Whenever I run [Menu]+Quit, I get this crash. Even when I then in the crash-applet say that Fennec should close, it restarts.
As the crash address moves every day (missing debug symbol), I think it's a dupe of bug 756140 (e is close to d in hexa).
OS: Linux → Android
Hardware: All → ARM
Summary: crash in libxul → crash in libxul.so@0xe41046
Whiteboard: [native-crash]
Cynogen mod on Nexus S; we don't have debug symbols on Cynogenmod is my guess and that's why we're seeing libxul instead of the appropriate signature.  Crashes depend on where they get loaded in memory, so we would have to examine each crash address separately in order to make this actionable ... or get symbols to work on cynogenmod... in some cases the same crash signature could be a different crash (ie on different devices) or other cases different crash signatures could be the same crash (again different devices)
I concur with Scoobidiver that this may be a dup of bug 756140
Which system we run on has *no* influence at all on having symbols for libxul.so - and actually, if you look at the other threads, you find libxul.so frames that are properly symbolized.

As bug 756140 comment #13 explains, we have invalid reads and writes happening, and I think this might mess up the stack in a way that we end up with an address on the stack that we just cannot dereference to a function name properly - not because symbols are missing, but because it might not be an address that points to a valid function in the binary (or something like that).
Matej, does it still happen?
Flags: needinfo?(mcepl)
(In reply to Scoobidiver from comment #5)
> Matej, does it still happen?

Well, Firefox itself doesn't have File/Quit menu item anymore in Nightly, so I cannot reproduce 100%, but when Quiting webapps (which have Quit menu item) I don't get crash anymore, so I guess this got fixed somewhere.

Thanks for keeping up with this bug (and sorry for my getting swallowed by the Christmas craziness and missing on this needinfo).
Flags: needinfo?(mcepl)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.