Last Comment Bug 758913 - Remove JSCLASS_NEW_RESOLVE_GETS_START
: Remove JSCLASS_NEW_RESOLVE_GETS_START
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 758912
Blocks: 751377
  Show dependency treegraph
 
Reported: 2012-05-26 15:03 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2012-06-22 09:16 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.25 KB, patch)
2012-06-05 17:40 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
dmandelin: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2012-05-26 15:03:19 PDT
JSCLASS_NEW_RESOLVE_GETS_START specifies that resolve hooks be passed not just the object associated with the resolve hook, but the start object where the lookup started.  But in the ECMAScript algorithms, only the resolve-hook object is passed along -- there's no way to get the start object.  In order to implement the standard algorithms, then, I need to remove this flag.

There's only one use in Gecko that must be addressed (see bug 758912).  It's unknown whether any other embedders use it.  I've posted to the newsgroup asking if anyone does; hopefully we can figure out workarounds for anyone who does:

https://groups.google.com/forum/?fromgroups#!topic/mozilla.dev.tech.js-engine/da_9XU2XOD4
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-05-27 16:32:41 PDT
Note that this flag was added specifically for that Gecko use, by the way.
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-06-05 17:40:06 PDT
Created attachment 630388 [details] [diff] [review]
Patch

This depends on bug 758912 landing first, of course.

The newsgroup post got no responses from anyone else using this, so it seems possible that Gecko was the only user (especially given what comment 1 says), and we need not worry about breaking any JSAPI clients.
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2012-06-22 02:05:42 PDT
The prereq just got completed, so landed:

https://hg.mozilla.org/integration/mozilla-inbound/rev/026eb5f84c55

And a good thing, too, because the DOM accessor perf work needs a JSCLASS_* flag.  :-D

Excelsior!
Comment 4 Ed Morley [:emorley] 2012-06-22 09:16:38 PDT
https://hg.mozilla.org/mozilla-central/rev/026eb5f84c55

Note You need to log in before you can comment on or make changes to this bug.