Last Comment Bug 758980 - Certain font disappears when page scroll down and resize width
: Certain font disappears when page scroll down and resize width
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 15 Branch
: x86 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Bas Schouten (:bas.schouten)
:
Mentors:
Depends on:
Blocks: 715768
  Show dependency treegraph
 
Reported: 2012-05-27 11:42 PDT by Alice0775 White
Modified: 2012-08-03 05:09 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
html and font (2.26 MB, application/x-zip)
2012-05-27 11:42 PDT, Alice0775 White
no flags Details
another html (2.26 MB, application/x-zip)
2012-05-27 11:49 PDT, Alice0775 White
no flags Details
html (58.33 KB, text/html)
2012-05-27 12:16 PDT, Alice0775 White
no flags Details
another html (58.25 KB, text/html)
2012-05-27 12:16 PDT, Alice0775 White
no flags Details
font (3.62 MB, application/x-font-ttf)
2012-06-03 13:38 PDT, Alice0775 White
no flags Details
Assume directwrite is buggy when it returns empty alpha texture bounds. (1.10 KB, patch)
2012-06-03 19:42 PDT, Bas Schouten (:bas.schouten)
jmuizelaar: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Alice0775 White 2012-05-27 11:42:28 PDT
Created attachment 627578 [details]
html and font

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/133aa3a2ef0a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120527030515

Font disappears when page scroll down and resize width

Steps to reproduce:

1. Install font JSGOTHIC.TTC
2. Open index.html
3. Scroll down and resize window width if necessary

Actual results:
  Font disappears

Expected results:
  Should not


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/36e938e51481
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120523030525
Bad:
http://hg.mozilla.org/mozilla-central/rev/aa2b52bd0374
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=36e938e51481&tochange=aa2b52bd0374

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/bbb12d0bcf49
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120521220651
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/abbf642df562
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120521222950
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bbb12d0bcf49&tochange=abbf642df562

Triggered by:
abbf642df562	Bas Schouten — Bug 715768: Enable Azure-Thebes wrapper by default for D2D. r=jrmuizel


Setting gfx.content.azure.enabled to false helps
Comment 1 Alice0775 White 2012-05-27 11:45:51 PDT
Graphics
Adapter Description : ATI Radeon HD 4300/4500 Series
Vendor ID : 0x1002
Device ID : 0x954f
Adapter RAM : 512
Adapter Drivers : aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version : 8.961.0.0
Driver Date : 4-5-2012
Direct2D Enabled : true
DirectWrite Enabled : true (6.1.7601.17789)
ClearType Parameters : Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 200 
WebGL Renderer : Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows : 1/1 Direct3D 10
AzureBackend : direct2d
Comment 2 Alice0775 White 2012-05-27 11:49:31 PDT
Created attachment 627579 [details]
another html
Comment 3 Alice0775 White 2012-05-27 12:16:25 PDT
Created attachment 627583 [details]
html
Comment 4 Alice0775 White 2012-05-27 12:16:57 PDT
Created attachment 627584 [details]
another html
Comment 5 Alice0775 White 2012-05-27 12:47:01 PDT
Screen capture: http://youtu.be/BQ8eW6YQrF8
Comment 6 Alice0775 White 2012-05-27 12:51:39 PDT
And also setting gfx.font_rendering.cleartype_params.rendering_mode to 5 helps
Comment 7 Bas Schouten (:bas.schouten) 2012-06-03 13:10:59 PDT
Pardon my ignorance, but where do I find jsgothic.ttc? :)
Comment 8 Alice0775 White 2012-06-03 13:38:39 PDT
Created attachment 629647 [details]
font
Comment 9 Bas Schouten (:bas.schouten) 2012-06-03 19:42:44 PDT
Created attachment 629680 [details] [diff] [review]
Assume directwrite is buggy when it returns empty alpha texture bounds.

This fixes the issue, this falls back to traditional rendering when DirectWrite is returning empty bounds for the alpha texture, which seems to be indicative of this problem.
Comment 10 Jeff Muizelaar [:jrmuizel] 2012-06-04 18:05:17 PDT
John, Bas, is there any chance we can get a reduced test case of what ever this font is doing?
Comment 11 Jeff Muizelaar [:jrmuizel] 2012-06-04 18:06:58 PDT
(In reply to Bas Schouten (:bas) from comment #9)
> Created attachment 629680 [details] [diff] [review]
> Assume directwrite is buggy when it returns empty alpha texture bounds.
> 
> This fixes the issue, this falls back to traditional rendering when
> DirectWrite is returning empty bounds for the alpha texture, which seems to
> be indicative of this problem.

Do you know why setting gfx.content.azure.enabled to false helps?
Comment 12 Bas Schouten (:bas.schouten) 2012-06-05 18:02:43 PDT
(In reply to Jeff Muizelaar [:jrmuizel] from comment #11)
> (In reply to Bas Schouten (:bas) from comment #9)
> > Created attachment 629680 [details] [diff] [review]
> > Assume directwrite is buggy when it returns empty alpha texture bounds.
> > 
> > This fixes the issue, this falls back to traditional rendering when
> > DirectWrite is returning empty bounds for the alpha texture, which seems to
> > be indicative of this problem.
> 
> Do you know why setting gfx.content.azure.enabled to false helps?

Yes, cairo-d2d-surface.cpp:3752 has the same logic there.
Comment 13 Jeff Muizelaar [:jrmuizel] 2012-06-12 23:17:26 PDT
Comment on attachment 629680 [details] [diff] [review]
Assume directwrite is buggy when it returns empty alpha texture bounds.

Review of attachment 629680 [details] [diff] [review]:
-----------------------------------------------------------------

Reluctant r+ because of lack of test. Please put a reference to this bug in a comment nearby.
Comment 14 Bas Schouten (:bas.schouten) 2012-06-13 01:56:51 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d846a8245199
Comment 15 Matt Brubeck (:mbrubeck) 2012-06-13 13:29:45 PDT
https://hg.mozilla.org/mozilla-central/rev/d846a8245199
Comment 16 Bas Schouten (:bas.schouten) 2012-06-19 14:53:19 PDT
Comment on attachment 629680 [details] [diff] [review]
Assume directwrite is buggy when it returns empty alpha texture bounds.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 715768
User impact if declined: On rare occasions missing fonts
Testing completed (on m-c, etc.): Several days m-c
Risk to taking this patch (and alternatives if risky): Very low, this is really unlikely to have a negative impact.
String or UUID changes made by this patch: None
Comment 17 Alex Keybl [:akeybl] 2012-06-19 20:10:26 PDT
Comment on attachment 629680 [details] [diff] [review]
Assume directwrite is buggy when it returns empty alpha texture bounds.

[Triage Comment]
Low risk fix for a regression in FF15. Approved for Aurora.
Comment 18 Bas Schouten (:bas.schouten) 2012-07-17 09:03:04 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/1513818e3c54
Comment 19 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-18 09:11:03 PDT
[Triage comment]
Updating the status flags since this has landed on Beta (15).
Comment 20 Ioana (away) 2012-08-03 05:09:06 PDT
Verified as fixed with the reporter's test cases on:
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Note You need to log in before you can comment on or make changes to this bug.