Last Comment Bug 759061 - nsINIParser.cpp fails to compile on mingw
: nsINIParser.cpp fails to compile on mingw
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 02:37 PDT by Jacek Caban
Modified: 2012-06-01 08:42 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (1.03 KB, patch)
2012-05-28 02:37 PDT, Jacek Caban
timabraldes: review+
Details | Diff | Splinter Review

Description Jacek Caban 2012-05-28 02:37:36 PDT
Created attachment 627642 [details] [diff] [review]
fix v1.0

That's because of usage of assignment statement for initializing, which is not compatible with GCC. See https://bugzilla.mozilla.org/show_bug.cgi?id=733708#c3 for detailed explanation.
Comment 1 Tim Abraldes [:TimAbraldes] [:tabraldes] 2012-05-30 11:41:50 PDT
Comment on attachment 627642 [details] [diff] [review]
fix v1.0

Review of attachment 627642 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry about the delay; I've been out of town.  This fix looks good, thanks for taking care of this!
Comment 2 Jacek Caban 2012-05-31 07:10:44 PDT
Thanks for the review.

https://hg.mozilla.org/integration/mozilla-inbound/rev/fe129d98513e
Comment 3 Ed Morley [:emorley] 2012-06-01 08:42:47 PDT
https://hg.mozilla.org/mozilla-central/rev/fe129d98513e

Note You need to log in before you can comment on or make changes to this bug.