Last Comment Bug 759115 - Bump minimum Android SDK API level we require to 14
: Bump minimum Android SDK API level we require to 14
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: mozilla16
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on: 765808
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 08:20 PDT by Mike Hommey [:glandium]
Modified: 2012-06-18 21:04 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Bump minimum Android SDK API level we require to 14 (1.17 KB, patch)
2012-05-28 08:21 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Move Android SDK/NDK checks in build/autoconf/android.m4, and bump minimum Android SDK API level we require to 14 for mobile/android (41.04 KB, patch)
2012-06-04 00:37 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Move Android SDK/NDK checks in build/autoconf/android.m4, and bump minimum Android SDK API level we require to 14 for mobile/android (40.50 KB, patch)
2012-06-04 03:00 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-05-28 08:20:50 PDT
When building with SDK 13, which is currently allowed, one gets the following build failure:

res/values-xlarge/themes.xml:17: error: Error: No resource found that matches the given name: attr 'android:actionBarDivider'.
res/values-sw600dp/themes.xml:17: error: Error: No resource found that matches the given name: attr 'android:actionBarDivider'.
make[6]: *** [R.java] Error 1
Comment 1 Mike Hommey [:glandium] 2012-05-28 08:21:59 PDT
Created attachment 627704 [details] [diff] [review]
Bump minimum Android SDK API level we require to 14
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-05-29 05:58:13 PDT
Comment on attachment 627704 [details] [diff] [review]
Bump minimum Android SDK API level we require to 14

Review of attachment 627704 [details] [diff] [review]:
-----------------------------------------------------------------

This doesn't change our runtime compat requirements, just the version of the SDK we require, right?
Comment 3 Mike Hommey [:glandium] 2012-05-29 07:56:36 PDT
(In reply to Ted Mielczarek [:ted] from comment #2)
> This doesn't change our runtime compat requirements, just the version of the
> SDK we require, right?

Indeed.
Comment 4 Mike Hommey [:glandium] 2012-05-30 00:38:20 PDT
https://hg.mozilla.org/mozilla-central/rev/d8e75ef4e5ad
Comment 5 Mike Hommey [:glandium] 2012-05-30 00:49:42 PDT
Backed out, we use android-13 for android XUL (and it's fine).
https://hg.mozilla.org/mozilla-central/rev/65fa5cb6f79c
Comment 6 Mike Hommey [:glandium] 2012-06-04 00:37:42 PDT
Created attachment 629715 [details] [diff] [review]
Move Android SDK/NDK checks in build/autoconf/android.m4, and bump minimum Android SDK API level we require to 14 for mobile/android

Mostly, this moves stuff around, and just adds a check on the target application to set the minimum android sdk api level accordingly.
https://tbpl.mozilla.org/?noignore=1&tree=Try&rev=7c9f4fa9c5a1
Comment 7 Mike Hommey [:glandium] 2012-06-04 03:00:57 PDT
Created attachment 629733 [details] [diff] [review]
Move Android SDK/NDK checks in build/autoconf/android.m4, and bump minimum Android SDK API level we require to 14 for mobile/android

Without the egg-info change (yay for egg-info in the tree).
Comment 9 Mike Hommey [:glandium] 2012-06-10 23:24:31 PDT
Backed out because of B2G bustage
https://hg.mozilla.org/integration/mozilla-inbound/rev/c7e76fae10e5
Comment 10 Mike Hommey [:glandium] 2012-06-11 02:05:09 PDT
Relanded with basic fixups
https://hg.mozilla.org/integration/mozilla-inbound/rev/a430a3d30163
Comment 11 Graeme McCutcheon [:graememcc] 2012-06-12 03:07:02 PDT
https://hg.mozilla.org/mozilla-central/rev/a430a3d30163
Comment 12 Alphat-PC 2012-06-17 08:04:39 PDT
Typo?

diff --git a/js/src/aclocal.m4 b/js/src/aclocal.m4
--- a/js/src/aclocal.m4
+++ b/js/src/aclocal.m4
@@ -17,6 +17,6 @@ builtin(include, build/autoconf/frameptr
 builtin(include, build/autoconf/compiler-opts.m4)dnl
 builtin(include, build/autoconf/expandlibs.m4)dnl
 builtin(include, build/autoconf/arch.m4)dnl
-builtin(include, build/autoconf/android.m4)dn
+builtin(include, build/autoconf/android.m4)dnl
 
 MOZ_PROG_CHECKMSYS()

Note You need to log in before you can comment on or make changes to this bug.