Last Comment Bug 759213 - IonMonkey: Assertion failure: isObject(), at ../../jsapi.h:476 or Crash [@ js::UnwindIteratorForUncatchableException]
: IonMonkey: Assertion failure: isObject(), at ../../jsapi.h:476 or Crash [@ js...
Status: RESOLVED FIXED
[jsbugmon:update]
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86_64 Linux
: -- major (vote)
: ---
Assigned To: David Anderson [:dvander]
:
: Jason Orendorff [:jorendorff]
Mentors:
: 759314 (view as bug list)
Depends on:
Blocks: langfuzz IonFuzz
  Show dependency treegraph
 
Reported: 2012-05-28 15:52 PDT by Christian Holler (:decoder)
Modified: 2013-01-14 08:17 PST (History)
7 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (5.37 KB, patch)
2012-05-30 10:11 PDT, David Anderson [:dvander]
jdemooij: review+
Details | Diff | Splinter Review

Description Christian Holler (:decoder) 2012-05-28 15:52:37 PDT
The following testcase asserts on ionmonkey revision 4ce3983a43f4 (run with --ion -n -m --ion-eager):


function testNestedForIn() {
    var a = {x: 1, y: (/\\u00fd[]/ ), z: 3};
    for (var p1 in a)
        for (var { w  }  = 0     ;  ;    )
            testJSON(t);
}
assertEq(testNestedForIn(), 'xx xy xz yx yy yz zx zy zz ');
Comment 1 David Anderson [:dvander] 2012-05-30 10:11:39 PDT
Created attachment 628371 [details] [diff] [review]
fix

The bug is that an inner loop creates a phi for an iterator object, but this phi is not observable so it gets removed. The fix here should scale easily to chunked compilation.
Comment 2 Jan de Mooij [:jandem] 2012-05-30 10:57:53 PDT
Comment on attachment 628371 [details] [diff] [review]
fix

Review of attachment 628371 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Comment 3 David Anderson [:dvander] 2012-05-30 13:16:11 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/0930379f5cfa
Comment 4 David Anderson [:dvander] 2012-05-30 22:29:41 PDT
*** Bug 759314 has been marked as a duplicate of this bug. ***
Comment 5 Christian Holler (:decoder) 2013-01-14 08:17:49 PST
A testcase for this bug was automatically identified at js/src/jit-test/tests/ion/bug759213.js.

Note You need to log in before you can comment on or make changes to this bug.