Last Comment Bug 759263 - virtualenv uses CFLAGS instead of HOST_CFLAGS
: virtualenv uses CFLAGS instead of HOST_CFLAGS
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla16
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 01:50 PDT by Jacek Caban
Modified: 2012-06-12 03:07 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (813 bytes, patch)
2012-05-29 01:50 PDT, Jacek Caban
ted: review+
Details | Diff | Review

Description Jacek Caban 2012-05-29 01:50:50 PDT
Created attachment 627882 [details] [diff] [review]
fix v1.0

It should use HOST_CFLAGS as well as a few other variables, probably (my patch addresses also CXXFLAGS and LDFLAGS). Setting them explicitly in Makefile seems to be the right fix.

Try push:
https://tbpl.mozilla.org/?tree=Try&rev=0a587e837079
Comment 1 Jacek Caban 2012-05-29 02:30:12 PDT
I did try push based on wrong tree. Here is the right one (I will cancel previous builds):

https://tbpl.mozilla.org/?tree=Try&rev=7118a5c06fcc
Comment 2 Marco Perez 2012-05-29 15:10:43 PDT
This patch improves the situation on FreeBSD, where the builds were broken by the "unified virtualenv" landing. There's still some "-L/usr/local/lib" missing to get things going again.
I doubt that it should be hard-coded into the Makefile, but I haven't found out what other variable could be added to fix that remaining issue.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-06-08 12:42:28 PDT
Comment on attachment 627882 [details] [diff] [review]
fix v1.0

Review of attachment 627882 [details] [diff] [review]:
-----------------------------------------------------------------

Bleh.
Comment 5 Graeme McCutcheon [:graememcc] 2012-06-12 03:07:11 PDT
https://hg.mozilla.org/mozilla-central/rev/87a43f124ee9

Note You need to log in before you can comment on or make changes to this bug.