document.open() content rewriting results in blurry rendering >2 screens down

RESOLVED DUPLICATE of bug 747883

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 747883
6 years ago
2 years ago

People

(Reporter: Roman Rudenko, Unassigned)

Tracking

12 Branch
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 627914 [details]
docwrite_blur.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.52 Safari/536.5

Steps to reproduce:

Loaded attached "docwrite_blur.html" testcase into Firefox Beta 12.0 and Aurora 14.0a2 (2012-05-28) on Samsung Galaxy Nexus with Android 4.0.2.
Scrolled down until "line 49".


Actual results:

Starting from very bottom of line 48, test is blurry and blotchy.
The point of breakage appears to be a fixed number of pixels away from the top
(so font size increases allow fewer readable lines).
Testing on more complex testcases shows that images and other elements are affected as well.


Expected results:

Proper text rendering.
(Reporter)

Comment 1

6 years ago
Created attachment 627916 [details]
Screenshot of bug
(Reporter)

Updated

6 years ago
OS: Mac OS X → Android
Hardware: x86 → All
(Reporter)

Comment 2

6 years ago
Other notes: this bug blocks support of Fennec by Mobify-based mobile websites, as Mobify heavily relies on replacing an existing document via document.open().
Likely a dupe of bug 747883.
Looks like bug 747883 has a fix that has landed on mozilla-central and is now on Nightly. Roman, can you re-test using the latest Nightly (http://nightly.mozilla.org). If such is the case that this issue is non-reproducible anymore, we should dupe this bug over to bug 747883.
(Reporter)

Comment 5

6 years ago
Yes, the issue is fixed. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747883
You need to log in before you can comment on or make changes to this bug.