Last Comment Bug 759333 - Update tests have to obey 'Applying update...' state since bug 307181 has been landed
: Update tests have to obey 'Applying update...' state since bug 307181 has bee...
Status: RESOLVED FIXED
[lib]
: regression
Product: Mozilla QA
Classification: Other
Component: Mozmill Tests (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Henrik Skupin (:whimboo)
:
:
Mentors:
http://mozmill-ci.blargon7.com/#/upda...
Depends on:
Blocks: bgupdates
  Show dependency treegraph
 
Reported: 2012-05-29 07:30 PDT by Henrik Skupin (:whimboo)
Modified: 2012-05-30 02:12 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch v1 (2.67 KB, patch)
2012-05-29 08:47 PDT, Henrik Skupin (:whimboo)
no flags Details | Diff | Splinter Review
Patch v1.1 (3.26 KB, patch)
2012-05-29 08:49 PDT, Henrik Skupin (:whimboo)
dave.hunt: review+
Details | Diff | Splinter Review

Description Henrik Skupin (:whimboo) 2012-05-29 07:30:17 PDT
Those failures have been started recently and seem to happen more frequently but not permanent across platforms. 

test2.js::testDirectUpdate_Download 	

New wizard page has been selected - got downloading, expected finished
Comment 1 Henrik Skupin (:whimboo) 2012-05-29 07:32:14 PDT
For better results:
http://qa-masterblaster.mv.mozilla.com:8080/job/mozilla-central_update/1621/

Build from:
https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012/05/2012-05-29-03-05-18-mozilla-central/firefox-15.0a1.en-US.mac.dmg

*** Updating to branch 'default'
pulling from mozmill-tests
searching for changes
no changes found
0 files updated, 0 files merged, 0 files removed, 0 files unresolved
TEST-START | /var/folders/vq/bds4whmx4jg5n19nm5p_9xfr0000gp/T/tmpUaJnjZ.mozmill-tests/tests/update/testDirectUpdate/test1.js | setupModule
TEST-PASS | /var/folders/vq/bds4whmx4jg5n19nm5p_9xfr0000gp/T/tmpUaJnjZ.mozmill-tests/tests/update/testDirectUpdate/test1.js | test1.js::setupModule
TEST-START | /var/folders/vq/bds4whmx4jg5n19nm5p_9xfr0000gp/T/tmpUaJnjZ.mozmill-tests/tests/update/testDirectUpdate/test2.js | setupModule
TEST-PASS | /var/folders/vq/bds4whmx4jg5n19nm5p_9xfr0000gp/T/tmpUaJnjZ.mozmill-tests/tests/update/testDirectUpdate/test2.js | test2.js::setupModule
TEST-START | /var/folders/vq/bds4whmx4jg5n19nm5p_9xfr0000gp/T/tmpUaJnjZ.mozmill-tests/tests/update/testDirectUpdate/test2.js | testDirectUpdate_Download
TEST-UNEXPECTED-FAIL | /var/folders/vq/bds4whmx4jg5n19nm5p_9xfr0000gp/T/tmpUaJnjZ.mozmill-tests/tests/update/testDirectUpdate/test2.js | test2.js::testDirectUpdate_Download
TEST-START | /var/folders/vq/bds4whmx4jg5n19nm5p_9xfr0000gp/T/tmpUaJnjZ.mozmill-tests/tests/update/testDirectUpdate/test2.js | teardownModule
TEST-PASS | /var/folders/vq/bds4whmx4jg5n19nm5p_9xfr0000gp/T/tmpUaJnjZ.mozmill-tests/tests/update/testDirectUpdate/test2.js | test2.js::teardownModule
Comment 2 Henrik Skupin (:whimboo) 2012-05-29 07:51:30 PDT
The regression has been started on May 23rd and is most likely because of the background updates.

Passed: 20120522145033 (http://mozmill-ci.blargon7.com/#/update/report/f87375a634b1a5ba746e5f763a6e3512)
Failed: 20120523112744 (http://mozmill-ci.blargon7.com/#/update/report/f87375a634b1a5ba746e5f763a7386b1)

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b038090f07c2&tochange=320b16daa7c0

Ehsan, which of the patches could have regressed this? As what I can see it's because of applying the patch in the old updater ui. There should have probably been a new wizard page but now we re-use the 'downloading' one.

Simplest solution for us would be to wait a bit longer for the finished pane once the download has been finished.
Comment 3 :Ehsan Akhgari 2012-05-29 08:00:32 PDT
FWIW, there are no background updates related patches in that range.  If this is indeed caused by background updates, the correct solution is to increase the timeout, as I think I noted to Anthony some time ago.  Otherwise, you need to bisect the range to see what is causing this failure to happen.
Comment 4 Henrik Skupin (:whimboo) 2012-05-29 08:45:04 PDT
Sorry forgot that the updates were disabled for a couple of days last week. So the regression range is wrong. In fact it is a fallout from bug 307181, especially:

http://hg.mozilla.org/mozilla-central/diff/c20d415ef1b5/toolkit/mozapps/update/content/updates.js#l1.113

Given that no new pane has been used for the 'apply' state, waiting until the current pane is not the downloading pane should be sufficient for our case. I will attach a patch in a minute which works fine for me.
Comment 5 Henrik Skupin (:whimboo) 2012-05-29 08:47:37 PDT
Created attachment 627976 [details] [diff] [review]
Patch v1
Comment 6 Henrik Skupin (:whimboo) 2012-05-29 08:49:56 PDT
Created attachment 627978 [details] [diff] [review]
Patch v1.1

Fixed the alphabetical order in the declaration section and a single typo.
Comment 7 Dave Hunt (:davehunt) 2012-05-29 17:33:13 PDT
Comment on attachment 627978 [details] [diff] [review]
Patch v1.1

Looks good, and tests are passing for me. Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/3878a9948a38

Do we need to transplant this?
Comment 8 Henrik Skupin (:whimboo) 2012-05-30 02:12:48 PDT
Thanks Dave for landing this patch! No I do not think that we want to transplant it because it would need a different patch for the other branches, and once we have to merge one more patch is necessary. So lets bake it on mozilla-central and let it flow with the usual merge process.

Note You need to log in before you can comment on or make changes to this bug.