Last Comment Bug 759402 - crash in TraceXPCGlobal
: crash in TraceXPCGlobal
Status: RESOLVED FIXED
[js:t][startupcrash][qa?]
: crash, regression
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: 14 Branch
: x86 Windows 7
: -- critical (vote)
: mozilla16
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 10:49 PDT by Marcia Knous [:marcia - use ni]
Modified: 2012-08-28 02:50 PDT (History)
9 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
fixed
fixed


Attachments

Description Marcia Knous [:marcia - use ni] 2012-05-29 10:49:08 PDT
This bug was filed from the Socorro interface and is 
report bp-0aaca159-c330-4582-9d7b-5e58a2120529 .
============================================================= 

Seen while looking at Aurora crash stats. Fairly low volume crash - https://crash-stats.mozilla.com/report/list?signature=TraceXPCGlobal%28JSTracer*,%20JSObject*%29 

The crashes are present in a few other versions but in smaller volume.  Small spike occurred in 2012052604 build but crashes go back to 2012050104 build on Aurora.

Could be a shifting signature, not sure.

https://crash-stats.mozilla.com/report/index/0aaca159-c330-4582-9d7b-5e58a2120529

Frame 	Module 	Signature 	Source
0 	xul.dll 	TraceXPCGlobal 	js/xpconnect/src/nsXPConnect.cpp:1193
1 	mozjs.dll 	js::GCMarker::processMarkStackTop 	js/src/jsgcmark.cpp:1087
2 	mozjs.dll 	js::GCMarker::drainMarkStack 	js/src/jsgcmark.cpp:1131
3 	mozjs.dll 	MarkGrayAndWeak 	js/src/jsgc.cpp:2983
4 	mozjs.dll 	NonIncrementalMark 	js/src/jsgc.cpp:3251
5 	mozjs.dll 	GCCycle 	js/src/jsgc.cpp:3590
6 	mozjs.dll 	Collect 	js/src/jsgc.cpp:3692
7 	mozjs.dll 	js::GC 	js/src/jsgc.cpp:3713
8 	mozjs.dll 	js::DestroyContext 	js/src/jscntxt.cpp:277
9 	mozjs.dll 	JS_DestroyContext 	js/src/jsapi.cpp:1148
10 	xul.dll 	nsXPConnect::~nsXPConnect 	js/xpconnect/src/nsXPConnect.cpp:152
11 	xul.dll 	nsXPConnect::`scalar deleting destructor' 	
12 	xul.dll 	nsXPConnect::Release 	js/xpconnect/src/nsXPConnect.cpp:87
13 	xul.dll 	nsScriptSecurityManager::Shutdown 	caps/src/nsScriptSecurityManager.cpp:3465
14 	xul.dll 	nsComponentManagerImpl::KnownModule::~KnownModule 	xpcom/components/nsComponentManager.h:207
15 	xul.dll 	nsTArray<nsAutoPtr<nsComponentManagerImpl::KnownModule>,nsTArrayDefaultAllocator 	obj-firefox/dist/include/nsTArray.h:1243
16 	xul.dll 	nsTArray<nsAutoPtr<nsComponentManagerImpl::KnownModule>,nsTArrayDefaultAllocator 	obj-firefox/dist/include/nsTArray.h:963
17 	xul.dll 	nsTArray<nsAutoPtr<nsComponentManagerImpl::KnownModule>,nsTArrayDefaultAllocator 	obj-firefox/dist/include/nsTArray.h:974
18 	xul.dll 	nsComponentManagerImpl::Shutdown 	xpcom/components/nsComponentManager.cpp:770
19 	xul.dll 	mozilla::ShutdownXPCOM 	xpcom/build/nsXPComInit.cpp:707
20 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3879
21 		@0x341451f 	
22 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
23 	msvcr100.dll 	_initterm 	f:\dd\vctools\crt_bld\self_x86\crt\src\crt0dat.c:872
24 	firefox.exe 	__tmainCRTStartup 	crtexe.c:552
25 	firefox.exe 	_SEH_epilog4 	
26 	kernel32.dll 	BaseProcessStart 	
27 	kernel32.dll 	_SEH_epilog 	
28 	kernel32.dll 	BaseProcessStart 	
29 	firefox.exe 	pre_c_init 	crtexe.c:261
Comment 1 Scoobidiver (away) 2012-05-29 14:28:28 PDT
It's #45 top browser crasher in 14.0a2.
Comment 2 Alex Keybl [:akeybl] 2012-05-30 16:29:53 PDT
This appears to be outside out typical threhold for tracking top crashers. It's not yet clear to me if this is a regression in FF14. Can somebody confirm?
Comment 3 Scoobidiver (away) 2012-05-31 02:06:40 PDT
It was a very low volume crash but there was a spike in crashes from 14.0a2/20120427 (Aurora released). The Aurora regression range for the spike is:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=777c0bd7dd5d&tochange=3c87865c60ab
Comment 4 Alex Keybl [:akeybl] 2012-06-01 14:30:08 PDT
Tracking for FF14 release, although this may very well change after 14 is on beta since crash stats will be clearer.
Comment 5 Scoobidiver (away) 2012-06-12 08:51:57 PDT
It's #61 top browser crasher in 14.0b6.
Comment 6 David Mandelin [:dmandelin] 2012-06-19 17:00:01 PDT
Bobby, could you take a look at this? I'm wondering if it's a regression from CPG or the new DOM bindings.
Comment 7 Bobby Holley (:bholley) (busy with Stylo) 2012-06-20 01:06:48 PDT
This looks like bug 766018.
Comment 8 David Mandelin [:dmandelin] 2012-06-25 17:02:27 PDT
(In reply to Bobby Holley (:bholley) from comment #7)
> This looks like bug 766018.

Does that bug affect Firefox 14? If so, it might be worth backporting. But this crash seems to be only on 14, so maybe it's something else.
Comment 9 Scoobidiver (away) 2012-06-25 22:52:00 PDT
(In reply to David Mandelin from comment #8)
> But this crash seems to be only on 14, so maybe it's something else.
Those crashes occur in 14.0b8, the latest Aurora build and in Nightly up to 16.0a1/20120622030533.
The working range might be (low volume):
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=da85d45f39ef&tochange=bb4b37094b9f
Bug 766018 belongs indeed to this range.
Comment 10 Alex Keybl [:akeybl] 2012-07-10 12:53:48 PDT
Does this look fixed now? We uplifted bug 766018 to Beta, so our expectation is that this is no longer a problem.
Comment 11 Scoobidiver (away) 2012-07-10 14:23:22 PDT
(In reply to Alex Keybl [:akeybl] from comment #10)
> Does this look fixed now? We uplifted bug 766018 to Beta, so our expectation
> is that this is no longer a problem.
It's indeed fixed because there are no crashes in 14.0b11 and after 15.0a2/20120704.
Comment 12 Alex Keybl [:akeybl] 2012-07-10 16:05:05 PDT
(In reply to Scoobidiver from comment #11)
> (In reply to Alex Keybl [:akeybl] from comment #10)
> > Does this look fixed now? We uplifted bug 766018 to Beta, so our expectation
> > is that this is no longer a problem.
> It's indeed fixed because there are no crashes in 14.0b11 and after
> 15.0a2/20120704.

As always, thank you Scoobidiver :)
Comment 13 Ioana (away) 2012-08-10 06:28:41 PDT
This crash is still reproducing according to the Socorro interface:
https://crash-stats.mozilla.com/report/list?signature=TraceXPCGlobal%28JSTracer*,%20JSObject*%29

The stack traces for the crash from comment 0 and those on Firefox 15 07/31 are very similar but not identical. Please let me know if you see this as a different bug and I will file a new one.

Note You need to log in before you can comment on or make changes to this bug.