Closed Bug 759434 Opened 7 years ago Closed 7 years ago

floor_div is unused

Categories

(Core :: Graphics: Layers, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 797604

People

(Reporter: dzbarsky, Assigned: dzbarsky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
No description provided.
Attachment #628038 - Flags: review?(jones.chris.g)
Assignee: nobody → dzbarsky
Status: NEW → ASSIGNED
That function is used below.
Ah, you are right.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Attachment #628038 - Flags: review?(jones.chris.g)
clang warns about this, and I think the warning is kind of right.  Every time the header is included and the template is not instantiated, the function is unused.  I assume the compiler would not output the function in each translation unit that includes TiledLayerBuffer.h but I don't know.  I think floor_div should be marked inline (which would silence the warning) or changed to be a private static function on TiledLayerBuffer.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797604
I think it's worth actually silencing this warning instead of having other waste time on this.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Opps, the fix is actually in bug 797604. Carry on :)
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797604
You need to log in before you can comment on or make changes to this bug.