Closed Bug 759468 Opened 8 years ago Closed 6 years ago

PDF viewer doesn't handle some gradients, transparency, background images, and possibly colour profiles

Categories

(Firefox :: PDF Viewer, defect)

x86_64
All
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29

People

(Reporter: dbronaugh, Unassigned)

References

Details

(Whiteboard: [testday-20120622][pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161)

Attachments

(7 files)

Attached file villages_menu.pdf
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120526030519

Steps to reproduce:

Viewed PDF in Firefox (nightly, 2012-05-26) using the builtin pdf.js viewer. Awesome!


Actual results:

Rendering looked strange; partially transparent blocks around elements that should be transparent, etc; checked against Evince, many things are missing.


Expected results:

Viewing of PDF with all features used here supported.
Component: Untriaged → PDF Viewer
Attached image As viewed with evince
OS: Linux → All
I confirm the bug at aurora (Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120621 Firefox/15.0a2) and at the latest nightly (Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/16.0 Firefox/16.0a1)

Note: the message "This PDF document might not be displayed correctly" shows up at the reported pdf
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [testday-20120622]
Whiteboard: [testday-20120622] → [testday-20120622][pdfjs-c-rendering][pdfjs-d-smask][pdfjs-d-blend-mode]
Pdf exported from Indesign CS6 using Interactive settings looks absolutely terrible in this new firefox pdf viewer... colors are off-over saturated. Any effects (outer glows, drop-shadows become white background) Etc.

Awful and totally useless.
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0

Background color under transparent object does not render, result in an unreadable title text.
(in white)

https://www.dropbox.com/s/zt8k7lp7z8k6n3m/I18n%20L10n%20for%20PES.pdf?m
(to be attached)
Attached file I18n L10n for PES.pdf
Comment on attachment 722676 [details]
I18n L10n for PES.pdf

White title text in the slides cannot be seen due to background color under transparent object missing.
Attachment #722676 - Attachment description: White title text in the slides cannot be seen due to background color under transparent object missing. → I18n L10n for PES.pdf
Another testcase exhibiting transparency problems, originating URL:
http://yummyyummycuisine.com/pfd/dinner.pdf
Similar issues occuring with most of our online pdf content. We post our product literature for use by our customers on our website. Many of these documents have graphics as backgrounds, much like watermarks. PDF.JS is not rendering documents correctly, as it is not honoring transparency levels for these images and is instead rendering the images as completely opaque, thus obscuring text content and making the PDF largely useless. An example is at http://www.incord.com/pdf/Inflatables.pdf. Here there is an image used as a background for product text, but PDF.JS renders the image completely opaque so as to obscure the text. There are other pdfs linked at our site (http://www.incord.com/catalogs/index.htm) that suffer similar issues, with transparency levels being completely ignored in rendering. PDFs render correctly when viewed with Acrobat reader or accessed with other browsers. This is a significant issue for us and needs to be corrected in Firefox. I'm sure others are suffering the same ill effects of this integrated viewer and are likely loosing prospective business. As a longtime Firefox promoter I hope these issues can be resolved SOON.
Screenshot of file from our website (Inflatables.pdf) as rendered by PDF.JS
Screenshot of file from our website (Inflatables.pdf) as rendered by PDF.JS
@peterl@incord.com That pdf should look much better in the nightly version of firefox.  Still some slight issues because of the soft mask though.
Whiteboard: [testday-20120622][pdfjs-c-rendering][pdfjs-d-smask][pdfjs-d-blend-mode] → [testday-20120622][pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 965861
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Keywords: verifyme
Verified as fixed on Firefox 29 beta 1 (20140318013849) under Win 7 64-bit, Ubuntu 32-bit and Mac OS X 10.8.5.
All the attachments are now displayed correctly (except for one that still has problems under Ubuntu, I'll file a new separate bug).
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.