Last Comment Bug 759490 - Opus timestamps are not being used properly for seeking
: Opus timestamps are not being used properly for seeking
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Timothy B. Terriberry (:derf)
:
Mentors:
Depends on: 674225 758833
Blocks: 759399
  Show dependency treegraph
 
Reported: 2012-05-29 13:35 PDT by Timothy B. Terriberry (:derf)
Modified: 2012-06-01 08:40 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use Opus streams when seeking in Ogg, if present (10.33 KB, patch)
2012-05-29 13:44 PDT, Timothy B. Terriberry (:derf)
cajbir.bugzilla: review+
Details | Diff | Review

Description Timothy B. Terriberry (:derf) 2012-05-29 13:35:52 PDT
Opus streams are being ignored for seeking, and in at least one place (SeekBisection) it was looking for the (usually NULL) mVorbisState pointer instead of checking for either kind of stream. This could made random seeks in a large file stall eating 100% of the CPU.
Comment 1 Timothy B. Terriberry (:derf) 2012-05-29 13:44:38 PDT
Created attachment 628096 [details] [diff] [review]
Use Opus streams when seeking in Ogg, if present
Comment 2 Timothy B. Terriberry (:derf) 2012-05-31 10:37:13 PDT
Greenish on try: https://tbpl.mozilla.org/?tree=Try&rev=33c12ea9f51f
Comment 3 Timothy B. Terriberry (:derf) 2012-05-31 11:14:32 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/896f74fd3250
Comment 4 Ed Morley [:emorley] 2012-06-01 08:40:24 PDT
https://hg.mozilla.org/mozilla-central/rev/896f74fd3250

Note You need to log in before you can comment on or make changes to this bug.