Opus timestamps are not being used properly for seeking

RESOLVED FIXED in mozilla15

Status

()

Core
Audio/Video
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: derf, Assigned: derf)

Tracking

Trunk
mozilla15
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Opus streams are being ignored for seeking, and in at least one place (SeekBisection) it was looking for the (usually NULL) mVorbisState pointer instead of checking for either kind of stream. This could made random seeks in a large file stall eating 100% of the CPU.
(Assignee)

Updated

5 years ago
Assignee: nobody → tterribe
Blocks: 759399
Status: NEW → ASSIGNED
Depends on: 758833
(Assignee)

Comment 1

5 years ago
Created attachment 628096 [details] [diff] [review]
Use Opus streams when seeking in Ogg, if present
Attachment #628096 - Flags: review?(chris.double)
(Assignee)

Updated

5 years ago
Depends on: 674225

Updated

5 years ago
Attachment #628096 - Flags: review?(chris.double) → review+
(Assignee)

Comment 2

5 years ago
Greenish on try: https://tbpl.mozilla.org/?tree=Try&rev=33c12ea9f51f
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/896f74fd3250
Target Milestone: --- → mozilla15

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/896f74fd3250
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.