Last Comment Bug 759656 - Some PopupNotification consumers expect a notification argument to the mainAction callback
: Some PopupNotification consumers expect a notification argument to the mainAc...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Firefox 16
Assigned To: Matthew N. [:MattN] (PTO Jun. 29 - Jul. 1)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 22:40 PDT by Matthew N. [:MattN] (PTO Jun. 29 - Jul. 1)
Modified: 2012-06-30 15:16 PDT (History)
2 users (show)
MattN+bmo: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v.1 Remove unused/unimplemented callback argument (1.62 KB, patch)
2012-05-29 22:40 PDT, Matthew N. [:MattN] (PTO Jun. 29 - Jul. 1)
margaret.leibovic: review+
Details | Diff | Review

Description Matthew N. [:MattN] (PTO Jun. 29 - Jul. 1) 2012-05-29 22:40:29 PDT
Created attachment 628234 [details] [diff] [review]
v.1 Remove unused/unimplemented callback argument

PopupNotifications.jsm does:

notification.mainAction.callback.call();
  and 
target.action.callback.call();

with no arguments to the action callbacks but some consumers are expecting an argument.

This patch just removes the unused argument from the two consumers.
Comment 1 :Margaret Leibovic 2012-05-30 07:16:25 PDT
Comment on attachment 628234 [details] [diff] [review]
v.1 Remove unused/unimplemented callback argument

Good spot. These probably crept in there because the notification bar API does take a parameter.
Comment 2 Matthew N. [:MattN] (PTO Jun. 29 - Jul. 1) 2012-06-26 21:56:21 PDT
https://hg.mozilla.org/integration/fx-team/rev/3532b3c14ae5
Comment 3 Tim Taubert [:ttaubert] 2012-06-30 15:16:51 PDT
https://hg.mozilla.org/mozilla-central/rev/3532b3c14ae5

Note You need to log in before you can comment on or make changes to this bug.