Last Comment Bug 759770 - Fix build error when warnings-as-errors in nsSVGUtils.cpp
: Fix build error when warnings-as-errors in nsSVGUtils.cpp
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
-- normal (vote)
: mozilla15
Assigned To: Mounir Lamouri (:mounir)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 389498
  Show dependency treegraph
 
Reported: 2012-05-30 08:28 PDT by Mounir Lamouri (:mounir)
Modified: 2012-06-01 02:50 PDT (History)
2 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.75 KB, patch)
2012-05-30 08:38 PDT, Mounir Lamouri (:mounir)
dholbert: review+
mounir: checkin+
Details | Diff | Splinter Review

Description User image Mounir Lamouri (:mounir) 2012-05-30 08:28:32 PDT
Patch coming (as soon as the build will succeed).
Comment 1 User image Mounir Lamouri (:mounir) 2012-05-30 08:38:43 PDT
Created attachment 628348 [details] [diff] [review]
Patch
Comment 2 User image Daniel Holbert [:dholbert] 2012-05-30 09:40:07 PDT
Comment on attachment 628348 [details] [diff] [review]
Patch

Explicitly ignoring the return value from fwrite is probably bad in general, since we might want to check it for failure, but it's not worth it in this instance since this is debug-only logging code.

So, r=me -- thanks!
Comment 3 User image Daniel Holbert [:dholbert] 2012-05-30 09:41:57 PDT
Actually, it looks like this entire function is unused.  Maybe we should just delete it.
http://mxr.mozilla.org/mozilla-central/search?string=writeppm
Comment 4 User image Daniel Holbert [:dholbert] 2012-05-30 09:44:56 PDT
Mm, per bug 389498 comment 13, it sounds like this function is intentionally unused & might be handy for debugging from time to time.

Let's just land the patch as-is.
Comment 5 User image Ed Morley [:emorley] 2012-05-31 06:33:50 PDT
https://hg.mozilla.org/mozilla-central/rev/9bddce44625c
Comment 6 User image :Ms2ger (⌚ UTC+1/+2) 2012-06-01 02:42:39 PDT
(In reply to Ed Morley [:edmorley] from comment #5)
> https://hg.mozilla.org/mozilla-central/rev/9bddce44625c

Empty patch
Comment 7 User image Mounir Lamouri (:mounir) 2012-06-01 02:50:31 PDT
I don't know what happened... I've very likely imported the wrong patch in my m-i repo.
Anyhow:
https://hg.mozilla.org/mozilla-central/rev/cb648ec7d7f2

Thank you for noticing that Ms2ger ;)

Note You need to log in before you can comment on or make changes to this bug.